Package Base Details: voglperf

Git Clone URL: https://aur.archlinux.org/voglperf.git (read-only)
Submitter: JonnyJD
Maintainer: JonnyJD
Last Packager: JonnyJD
Votes: 10
Popularity: 0.000000
First Submitted: 2014-10-14 13:04
Last Updated: 2015-11-01 21:12

Packages (2)

Latest Comments

« First ‹ Previous 1 2

JonnyJD commented on 2015-02-19 11:13

I did split the volgperf package into voglperf32 (including voglperfrun32) and voglperf64 (including voglperfrun64). There is no symlink voglperfrun available anymore. Use the one that is appropriate for your task. (upstream never had such a link)

Since this is a split package, the work required to install voglperf32 and voglperf64 is only one additional `pacman -U` (or getting both in one run).
The packages are set to replace the voglperf package.

This way you also have the opportunity to skip installing voglperf32 or voglperf64.

Please tell me if there are any problems. I only tested on my 64 bit system so far, but it the voglperf32 package should work on 32 bit, too. (voglperf64 obviously only runs on 64 bit, but shouldn't produce errors packaging.)

JonnyJD commented on 2015-02-19 09:44

What I could do though:
split into voglperf installing voglperf32 or voglperf64 (just voglperf?), depending on architecture and voglperf32 which is only available for 64 bit and installs voglperf32.
The problem with the current package is that it has different contents for different archictectures.

For 64 bit systems this would mean installing two packages manually though, since you often want to check the performance of 32 bit games with it, even on 64 bit systems.

So I only do that if anybody feels the need.

JonnyJD commented on 2015-02-19 09:34

I patched the Makefiles to use ncurses directly and also include lib32-ncurses in the deps on 64 bit systems now. (doesn't show on AUR; but is in the PKGBUILD)

To be clear: this package doesn't depend on libtinfo at all anymore.
(which was a symlink to ncurses anyway)

JLSalvador commented on 2015-02-19 00:27

It requires lib32-libtinfo (aur) in x64 platform. Thanks in advance.

hells commented on 2014-10-26 22:54

No problem! Yeah I saw that was mentinoed at libtinfo, but I left it here also so anybody searching can figure it out. I agree with the cmake, but it wouldn't progress without it. Thanks for updating the build so fast!

JonnyJD commented on 2014-10-26 18:04

Thanks a lot for the report. That gcc-multilib must have been a bit difficult do find. Sorry about that.

cmake is interesting, since you only run plain make (which then runs cmake).

The missing link is a https://aur.archlinux.org/packages/libtinfo/ bug already reported there. (But it is good to mention that here, too)

hells commented on 2014-10-24 21:44

Thanks for the PKGBUILD :) But a few issues I had here and what I did to solve them.

First it also requires gcc-multilib and cmake. Next the libtinfo dependency isn't enough to build, I also needed to issue a "ln -s libtinfo.so.5 libtinfo.so" in /usr/lib.

Thanks again!