Package Base Details: wxgtk-dev

Git Clone URL: https://aur.archlinux.org/wxgtk-dev.git (read-only, click to copy)
Submitter: ibrokemypie
Maintainer: FabioLolix
Last Packager: wangqr
Votes: 12
Popularity: 0.21
First Submitted: 2017-11-16 12:42 (UTC)
Last Updated: 2022-06-08 13:38 (UTC)

Pinned Comments

wangqr commented on 2022-07-17 08:44 (UTC)

This package was providing the dev releases of wxwidgets, as an alternative to the old wxgtk* packages. Now wx 3.2 has released, and official repo has renamed wxgtk3 to wxwidgets-gtk3. As the dev release is currently behind stable release, it is recommended to install extra/wxwidgets-gtk3 in official repo.

Latest Comments

1 2 3 Next › Last »

FabioLolix commented on 2022-07-17 12:12 (UTC)

@gkatev 3.2.0 is a stable version

bkb commented on 2022-07-17 11:14 (UTC)

All these wx things are basically broken. Some needs a newer version, some needs the old one. A long chain of dependency made it impossible to even switch from old to new or new to old, without uninstalling nearly the OS

wangqr commented on 2022-07-17 08:44 (UTC)

This package was providing the dev releases of wxwidgets, as an alternative to the old wxgtk* packages. Now wx 3.2 has released, and official repo has renamed wxgtk3 to wxwidgets-gtk3. As the dev release is currently behind stable release, it is recommended to install extra/wxwidgets-gtk3 in official repo.

wangqr commented on 2022-03-05 16:12 (UTC)

@feNNec wxgtk3-dev is a split package of wxgtk-dev. You can find it here: https://aur.archlinux.org/packages/wxgtk3-dev

feNNec commented on 2022-02-24 19:16 (UTC) (edited on 2022-02-24 19:17 (UTC) by feNNec)

wxgtk3-dev not found in AUR ???

dobedobedo commented on 2022-01-22 14:35 (UTC)

Hi @wangqr, I submitted the AUR package python-wxpython-dev based on your PKGBUILD.
https://aur.archlinux.org/packages/python-wxpython-dev/
This name should not violate the first rule of the AUR submission guideline.
Feel free to take it over.

dobedobedo commented on 2022-01-17 15:31 (UTC)

@wangqr, may I ask for what reason the python-wxpython-dev package is not allowed?

wangqr commented on 2022-01-04 18:31 (UTC) (edited on 2022-01-11 13:36 (UTC) by wangqr)

@dobedobedo Sure. https://aur.archlinux.org/packages/python-wxpython41/

Edit: It is not allowed on AUR. Here's the backup: https://github.com/wangqr/PKGBUILDs/tree/master/python-wxpython41