Package Base Details: wxgtk-dev

Git Clone URL: https://aur.archlinux.org/wxgtk-dev.git (read-only, click to copy)
Submitter: ibrokemypie
Maintainer: wangqr
Last Packager: wangqr
Votes: 7
Popularity: 0.003269
First Submitted: 2017-11-16 12:42
Last Updated: 2021-04-16 14:29

Pinned Comments

wangqr commented on 2021-10-19 09:43

@reisen wx-config is provided as a symlink to wx-config-gtk3 in the split package wxgtk3-dev. This change was made due to the EOL of Gtk2 and the plan to drop any gtk2 dependencies. See also: https://archlinux.org/todo/gtk-2-eol/

Latest Comments

1 2 Next › Last »

wangqr commented on 2021-11-24 16:07

@dulice Looks like a soname issue. Have you tried recompiling filezilla after installed wxgtk-dev?

dulice commented on 2021-11-23 07:28

sorry, the error is for wxgtk-common-dev

dulice commented on 2021-11-23 06:44

After installed it if launch filezilla I have:

filezilla: error while loading shared libraries: libwx_gtk3u_aui-3.0.so.0: cannot open shared object file: No such file or directory

I guest must be changed "provided" in wxgtk3-dev or filezilla dependecies

wangqr commented on 2021-10-19 09:43

@reisen wx-config is provided as a symlink to wx-config-gtk3 in the split package wxgtk3-dev. This change was made due to the EOL of Gtk2 and the plan to drop any gtk2 dependencies. See also: https://archlinux.org/todo/gtk-2-eol/

reisen commented on 2021-10-19 04:18

This package does not provide the wx-config binary like the official wxgtk2 package does, which breaks any makefile that expects wx-config to be present. I know it provides wx-config-gtk2, but that's a different binary name.

wangqr commented on 2021-01-27 01:33

@ruy16109 official wxgtkX stays on wx 3.0.x. This AUR provides wx 3.1.x

ruy16109 commented on 2020-10-26 16:03

Just curious, what is the difference between this AUR and the official wxgtkX?

LindyBalboa commented on 2019-02-20 20:09

I recently got the ABI version mismatch error when trying to launch audacity. I eventually noticed the patch "make-abicheck-non-fatal.patch". This needs to be updated to reflect the new version in the directory names as well as the proper lines of code, starting at line 847 now instead.

Dark-Sky commented on 2018-10-07 14:49

I built this package today using Clean Chroot Manager and it built just fine for CubicSDR that now requires this version. CubicSDR also built and works also with this version. It remains to be seen if this version will break any of my other programs I have installed built using the old version though.

ibrokemypie commented on 2018-08-28 10:03

Shasum updated, disowning package as I no longer use it though.