Package Base Details: xen

Git Clone URL: https://aur.archlinux.org/xen.git (read-only)
Keywords: hypervisor virtualization xen
Submitter: sergej
Maintainer: mbroemme
Last Packager: mbroemme
Votes: 178
Popularity: 0.032575
First Submitted: 2009-11-09 11:22
Last Updated: 2019-04-29 22:03

Packages (2)

Anonymous comment on 2011-04-18 11:15

Hello! I can't build it! Compilation crashed with following errors:


gcc -O2 -fomit-frame-pointer -m64 -fno-strict-aliasing -std=gnu99 -Wall -Wstrict-prototypes -Wno-unused-value -Wdeclaration-after-statement -DNDEBUG -nostdinc -fno-builtin -fno-common -Wredundant-decls -iwithprefix include -Werror -Wno-pointer-arith -pipe -I/tmp/yaourt-tmp-root/aur-xen/src/xen-4.1.0/xen/include -I/tmp/yaourt-tmp-root/aur-xen/src/xen-4.1.0/xen/include/asm-x86/mach-generic -I/tmp/yaourt-tmp-root/aur-xen/src/xen-4.1.0/xen/include/asm-x86/mach-default -msoft-float -fno-stack-protector -fno-exceptions -mno-red-zone -fpic -fno-asynchronous-unwind-tables -DGCC_HAS_VISIBILITY_ATTRIBUTE -g -D__XEN__ -MMD -MF .cpupool.o.d -c cpupool.c -o cpupool.o
cpupool.c: In function ‘cpupool_add_domain’:
cpupool.c:359:9: error: variable ‘n_dom’ set but not used [-Werror=unused-but-set-variable]
cpupool.c: In function ‘cpupool_rm_domain’:
cpupool.c:384:9: error: variable ‘n_dom’ set but not used [-Werror=unused-but-set-variable]
cpupool.c:383:9: error: variable ‘cpupool_id’ set but not used [-Werror=unused-but-set-variable]
cc1: all warnings being treated as errors

make[4]: *** [cpupool.o] Error 1
make[4]: Leaving directory `/tmp/yaourt-tmp-root/aur-xen/src/xen-4.1.0/xen/common'
make[3]: *** [/tmp/yaourt-tmp-root/aur-xen/src/xen-4.1.0/xen/common/built_in.o] Error 2
make[3]: Leaving directory `/tmp/yaourt-tmp-root/aur-xen/src/xen-4.1.0/xen/arch/x86'
make[2]: *** [/tmp/yaourt-tmp-root/aur-xen/src/xen-4.1.0/xen/xen] Error 2
make[2]: Leaving directory `/tmp/yaourt-tmp-root/aur-xen/src/xen-4.1.0/xen'
make[1]: *** [install] Error 2
make[1]: Leaving directory `/tmp/yaourt-tmp-root/aur-xen/src/xen-4.1.0/xen'
make: *** [install-xen] Error 2
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build xen.

Anonymous comment on 2011-03-26 08:23

Xen 4.1 has been released !
http://www.xen.org/products/xen_source.html

haagch commented on 2011-02-18 09:39

I think you should use options=(!strip) in the PKGBUILD.
Do these people that don't have this problem have strip in makepkg.conf disabled?

Anonymous comment on 2011-02-07 20:14

Please add a backup line to the PKGBUILD so that xend-config and other files won't be replaced by the package's contents. Thanks.

haagch commented on 2011-01-25 23:33

I have most of multilib installed. What exactly do I need?
(At the time of the comment before I had gcc instead of gcc-multilib, I don't know why it keeps being replaced...)

Now:
/usr/bin/strip: Unable to recognise the format of the input file `./usr/share/xen/qemu/openbios-sparc32'

flavius commented on 2011-01-25 13:45

You also have to make arch multilib: https://wiki.archlinux.org/index.php/Arch64_FAQ#Multilib_Repository_-_Multilib_Project if you are on x86_64

haagch commented on 2011-01-25 09:30

/usr/bin/strip: Unable to recognise the format of the input file `./usr/share/xen/qemu/openbios-ppc'

Anonymous comment on 2011-01-18 08:05

Please add pyxml dependency, because "xm new" requires xmlproc.

robertfoster commented on 2011-01-01 22:38

updated patchset.python2 dependency for 64bit fixed.conflict with 2.6.36.2 headers fixed

Anonymous comment on 2010-12-17 09:32

python2 should be in x86_64 depends, not python.