Package Base Details: xen

Git Clone URL: https://aur.archlinux.org/xen.git (read-only, click to copy)
Keywords: hypervisor virtualization xen
Submitter: sergej
Maintainer: Refutationalist
Last Packager: Refutationalist
Votes: 182
Popularity: 0.30
First Submitted: 2009-11-09 11:22
Last Updated: 2021-04-15 09:43

Packages (2)

Pinned Comments

Refutationalist commented on 2021-04-15 09:56

1) 4.15.0-1 adds zstd kernel support, so the hook for that is no longer needed, but I'm not sure if ever made it out of my personal repo.

2) The -no-pie problem in linking is present in 4.15, and there's an included patch for that. It is now the only patch needed to compile cleanly on Arch.

3) As promised, stubdom has moved from building by default to not building by default, as no one has spoken up about using it. If I continue maintaining the package, the plan is to remove it in the next major release.

4) I haven't done anything about the SDL2 deps.

5) Unless a co-maintainer is added, this is likely going to be the last release for a few months as I'm going in for surgery to have a brain tumor removed next month.

Latest Comments

« First ‹ Previous ... 4 5 6 7 8 9 10 11 12 13 14 ... Next › Last »

ColonelThirtyTwo commented on 2020-03-04 01:27

Getting the same error as @schweratlet, installing with pikaur.

schweratlet commented on 2020-02-17 22:35

@mbroemme I'm getting the same error when trying to install (installing with yay -S xen. though I hope it doesn't make a difference.

make -C xentoollog install make[8]: Entering directory '/home/shogoro/.cache/yay/xen/src/xen-4.12.1/tools/ocaml/libs/xentoollog' python2 genlevels.py _xtl_levels.mli.in _xtl_levels.ml.in _xtl_levels.inc MLDEP MLC xentoollog.cmo MLA xentoollog.cma CC xentoollog_stubs.o xentoollog_stubs.c: In function 'stub_xtl_ocaml_vmessage': xentoollog_stubs.c:93:16: error: initialization discards 'const' qualifier from pointer target type [-Werror=discarded-qualifiers] 93 | value func = caml_named_value(xtl->vmessage_cb) ; | ^~~~~~~~~~~~~~~~ xentoollog_stubs.c: In function 'stub_xtl_ocaml_progress': xentoollog_stubs.c:123:16: error: initialization discards 'const' qualifier from pointer target type [-Werror=discarded-qualifiers] 123 | value func = caml_named_value(xtl->progress_cb) ; | ^~~~~~~~~~~~~~~~ cc1: all warnings being treated as errors )

It leaves a whole bunch of directories and then.

make[1]: [Makefile:74: install] Error 2 make[1]: Leaving directory '/home/shogoro/.cache/yay/xen/src/xen-4.12.1/tools' make: [Makefile:127: install-tools] Error 2 ==> ERROR: A failure occurred in build(). Aborting... Error making: xen

Is this in any way my fault? Any advice? I have installed Xen successfully before, more specifically twice 4-5 months ago both on a fresh install. This is the first time I'm encountering such an error. I've tried it several times.

eduncan911 commented on 2019-12-20 11:10

@FFY00 oh please do!

In regards to CIS, this is the only package remaining that we use outside of the official repos.

FFY00 commented on 2019-12-20 00:18

Hey, I want to move this to the official repos. Are you ok with that?

sl4mmy commented on 2019-12-19 15:26

@mbroemme - do you plan on dropping the python2 dependency in favor of python? Also, would you be willing to consider switching the brltty dependency to the brltty-minimal available in AUR?

Thanks in advance!

mbroemme commented on 2019-12-18 13:12

4.13.0 is available, will built and merge all changes requested in the comments in the next few days.

ArthurBorsboom commented on 2019-12-14 15:21

I have spent many hours the last days trying to get a VM running with UEFI (ovmf), but Xen keeps crashing (visible by "xl dmesg").

It is related to the used Arch ovmf package in combination with the Xen configure parameter in PKGBUILD

--with-system-ovmf=/usr/share/ovmf/x64/OVMF_CODE.fd

After removing this parameter, Xen uses its 'native' ovmf binary provided by

/usr/lib/xen/boot/ovmf.bin

and not the one from the arch ovmf package provided by

/usr/share/ovmf/x64/OVMF_CODE.fd /usr/share/ovmf/x64/OVMF_VARS.fd

Would you mind to either (for now) remove the ovmf configure parameter and/or solve the cause of the crashing Xen with the Arch ovmf package?

linuxninja commented on 2019-11-21 19:59

I ran into the same libiscsi.so.8 problem. Re-compiling Xen and re-installing resolved the issue.

geh commented on 2019-11-21 15:03

Hi sometroubles with xen when compile the package see below make[4]: Leaving directory '/tmp/trizen-geh/xen/src/xen-4.12.1/tools/ocaml' make[3]: [/tmp/trizen-geh/xen/src/xen-4.12.1/tools/../tools/Rules.mk:251: subdir-install-ocaml] Error 2 make[3]: Leaving directory '/tmp/trizen-geh/xen/src/xen-4.12.1/tools' make[2]: [/tmp/trizen-geh/xen/src/xen-4.12.1/tools/../tools/Rules.mk:246: subdirs-install] Error 2 make[2]: Leaving directory '/tmp/trizen-geh/xen/src/xen-4.12.1/tools' make[1]: [Makefile:74: install] Error 2 make[1]: Leaving directory '/tmp/trizen-geh/xen/src/xen-4.12.1/tools' make: [Makefile:127: install-tools] Error 2 ==> ERREUR : Une erreur s’est produite dans build(). Abandon… :: Unable to build xen - makepkg exited with code: 4

alaricljs commented on 2019-11-15 18:56

Post upgrade, xen cannot start Windows HVM since libiscsi got upgraded. Can you make that dependency build-time version specific?

[2019-11-15T12:09:35-0500] [ALPM] upgraded libiscsi (1.18.0-1 -> 1.19.0-1)

/usr/lib/libiscsi.so.9

/usr/lib/xen/bin/qemu-system-i386: error while loading shared libraries: libiscsi.so.8: cannot open shared object file: No such file or directory