Package Base Details: xen

Git Clone URL: https://aur.archlinux.org/xen.git (read-only)
Keywords: hypervisor virtualization xen
Submitter: sergej
Maintainer: mbroemme
Last Packager: mbroemme
Votes: 178
Popularity: 0.031603
First Submitted: 2009-11-09 11:22
Last Updated: 2019-04-29 22:03

Packages (2)

Refutationalist commented on 2010-10-21 20:13

Oh, about that patch: you'll want to add it to the PKGBUILD right after the first python change patch to get it to go cleanly, and you'll need to update the deps, obviously.

Refutationalist commented on 2010-10-21 20:11

Here's an incredibly brute force patch to allow it to build with the recent python changes: http://aur.pastebin.com/DYQCmUHx

I also have some improved init scripts and such-- but like this patch, they're kinda hackish right now.

nicedream commented on 2010-10-21 19:39

Seems to not compile with the recent change from python2 to python3.

nicedream commented on 2010-10-13 02:06

This package builds fine for me on my i686 server, but within a half hour of booting the system is unresponsive. Since the server is remote, I'm not sure if it's just the network that locks up, or the whole kernel. This happens with both the regular and dev dom0 kernels in the AUR.

Magicking commented on 2010-10-02 19:11

I experienced the same problem as robertmarq and resolved it by adding the evtchn module.

Anonymous comment on 2010-09-20 16:52

I can not start xend.
Error: Unable to connect to xend: No such file or directory. Is xend running?

start xenstored..
[root@sistemas sistemas]# xenstored
[root@sistemas sistemas]# FATAL: Failed to open evtchn device: No such file or directory

Refutationalist commented on 2010-09-15 06:46

At least on x86_64, I needed to start xenstored, then xend, then xenconsoled in order to get proper functioning under xen 4.0.1-- this is with the pv-ops git repository, stable branch.

luka commented on 2010-09-02 12:03

i have only one issue; when using vnc i can't start domu.
in log file there is an error:

xen be core: xen be core: can't open gnttab device
can't open gnttab device

luka commented on 2010-09-01 21:55

i found out that error is in xen-initscript.patch - in xend file, i have removed this patch and everything works now just fine :-)
also i can compile and run xen without any patches...

luka commented on 2010-09-01 21:54

hi,

i found out that error is in xen-initscript.patch - in xend file...

i have removed this patch and everything works now just fine...

also i can compile and run xen without any patches...