Package Base Details: xorg-server-dev

Git Clone URL: https://aur.archlinux.org/xorg-server-dev.git (read-only)
Keywords: X-ABI-EXTENSION_VERSION X-ABI-VIDEODRV_VERSION X-ABI-XINPUT_VERSION x-server
Submitter: Det
Maintainer: dbermond
Last Packager: dbermond
Votes: 19
Popularity: 0.007820
First Submitted: 2010-06-27 07:53
Last Updated: 2019-06-09 12:01

Latest Comments

« First ‹ Previous ... 6 7 8 9 10 11 12 13 14 15 16 ... Next › Last »

Det commented on 2011-11-19 22:14

1.11.2-3: "- Fix segmentation fault due to race conditions in Record extension (FS#24653) - Update git-fixes, add commit that fixes segfault-on-exit - Add patch to fix passive grabs with XI2 clients":
http://projects.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/xorg-server&id=3dd3e886dfa1aec5bbd1bc90a9625514a12d99b9

Det commented on 2011-11-07 13:52

1.11.2-2: Added latest upstream fixes.

Det commented on 2011-07-04 04:06

Yes, as I already said the _input_ ABI is 13 ("...an unsupported input driver ABI version (have 13.0, need < 13.0)"), while the video ABI is that 11.

The evdev package available on the repos should have the input ABI of 12 but it still worked for me. If you're not using something else you could try giving a shot with the git version (xf86-input-evdev-git) [1], which should work just fine as it uses the version 13 input ABI. The build's really fast anyway, it's just a single <50kB .so file (comes up in seconds).

But still, the new X server doesn't look good (whether it be because of the Nvidia driver or the server itself) so I recommend you to use either the X server available on the repos (which is 1.10.2) or 1.10.3 RC2 (1.10.2.902), which uses the same ABIs as the repo's server but includes some of the fixes you get with 1.11 RC1. I even use 1.10.3 RC2 myself since that's the best choice for me ATM (just changed the pkgver to '1.10.2.902' and the first md5sum line to '4f6823101715b363b936a50421898680').

[1] = http://aur.archlinux.org/packages.php?ID=41665

E: also, I'm not sure but the text "This server has a video driver ABI version of 11.0 that this driver does not officially support." might still come up even if you used the 280.04 Nvidia driver since the support for X server 1.11 (video ABI 11) is only preliminary and not supposed to work as it should.

Det commented on 2011-07-04 04:02

Yes, as I already said the _input_ ABI is 13 ("...an unsupported input driver ABI version (have 13.0, need < 13.0)"), while the video ABI is that 11.

The evdev package available on the repos should have the input ABI of 12 but it still worked for me. If you're not using something else you could try giving a shot with the git version (xf86-input-evdev-git) [1], which should work just fine as it uses the version 13 input ABI. The build's really fast anyway, it's just a single <50kB .so file (comes up in seconds).

But still, the new X server doesn't look good (whether it be because of the Nvidia driver or the server itself) so I recommend you to use either the X server available on the repos (which is 1.10.2) or 1.10.3 RC2 (1.10.2.902), which uses the same ABIs as the repo's server but includes some of the fixes you get with 1.11 RC1. I even use 1.10.3 RC2 myself since that's the best choice for me ATM (just changed the pkgver to '1.10.2.902' and the first md5sum line to '4f6823101715b363b936a50421898680').

[1] = http://aur.archlinux.org/packages.php?ID=41665

karabaja4 commented on 2011-07-03 20:37

Little help with this please:

================ WARNING WARNING WARNING WARNING ================
This server has a video driver ABI version of 11.0 that this
driver does not officially support. Please check
http://www.nvidia.com/ for driver updates or downgrade to an X
server with a supported driver ABI.
=================================================================
(WW) NVIDIA: The driver will continue to load, but may behave strangely.
(WW) NVIDIA: This driver was compiled against the X.Org server SDK from git commit b6c7b9b2f39e970cedb6bc1e073f901e28cb0fa3 and may not be compatible with the final version of this SDK.
(WW) NVIDIA: This server has an unsupported input driver ABI version (have 13.0, need < 13.0). The driver will continue to load, but may behave strangely.
(WW) module ABI major version (12) doesn't match the server's version (13)

and my xorg doesn't load (kinda freezes), that's using 280.04 nvidia binary driver?

Det commented on 2011-07-01 22:31

And of course, the input ABI of the new X server is v13 - the _video_ ABI is v11.

Det commented on 2011-06-30 17:37

Actually, don't bother. The new X server _sucks_. Or at least it does so with the latest nvidia driver (transparency issues, content of other windows is displayed in others, etc.).

Det commented on 2011-06-30 08:20

Finally. The nvidia driver 280.04 supports the new ABI, thus it supports the new X server 1.11 series.

Det commented on 2011-06-01 22:05

A lot of juicy changes with 1.11 RC1. All the 'extra patches' from [extra]'s xorg-server are included (in the sources) (with the exception of the 'die-ugly-pattern' fix).

Changelog: http://www.spinics.net/lists/xorg/msg52652.html

E: but of course, remember that if your video driver's ABI hasn't been bumped to this (13.0), you won't be able to use it. Nvidia driver 275.09's ABI is 12.0 and it didn't work even with force-loading.

Det commented on 2011-06-01 22:01

A lot of juicy fixes with 1.11 RC1. All the 'extra patches' from [extra]'s xorg-server are included (in the sources) (with the exception of the 'die-ugly-pattern' fix).

Changelog: http://www.spinics.net/lists/xorg/msg52652.html