Package Base Details: xorg-server-git

Git Clone URL: https://aur.archlinux.org/xorg-server-git.git (read-only)
Keywords: git x-server xorg xorg-server
Submitter: ilikenwf
Maintainer: yurikoles
Last Packager: yurikoles
Votes: 43
Popularity: 1.215897
First Submitted: 2008-08-07 19:05
Last Updated: 2019-09-01 21:01

Pinned Comments

yurikoles commented on 2019-05-29 15:00

PRs are welcome: https://github.com/yurikoles-aur/xorg-server-git

Latest Comments

1 2 3 4 5 6 ... Next › Last »

yurikoles commented on 2019-10-19 07:34

@hagabaka it's upstream issue https://gitlab.freedesktop.org/xorg/xserver/issues/914

hagabaka commented on 2019-10-18 21:50

I'm getting the following error. Any idea how to fix it?

In file included from /usr/include/EGL/eglplatform.h:122,
                 from /usr/include/epoxy/egl_generated.h:11,
                 from /usr/include/epoxy/egl.h:46,
                 from ../xserver/glamor/glamor_priv.h:43,
                 from ../xserver/hw/kdrive/ephyr/ephyr_glamor_xv.c:31:
/usr/include/X11/Xlib.h:222:2: error: conflicting types for ‘GC’
  222 | *GC;
      |  ^~
In file included from ../xserver/hw/kdrive/ephyr/../src/kdrive.h:36,
                 from ../xserver/hw/kdrive/ephyr/ephyr_glamor_xv.c:28:
../xserver/include/gcstruct.h:282:3: note: previous declaration of ‘GC’ was here
  282 | } GC;
      |   ^~
[317/814] Compiling C object 'Xext/02e353f@@libxserver_xext@sta/sync.c.o'.
ninja: build stopped: subcommand failed.

yurikoles commented on 2019-10-11 16:51

@aufkrawall please report upstream

aufkrawall commented on 2019-10-11 16:47

Ok, seems to be a regression in master. server-1.20-branch works.

aufkrawall commented on 2019-10-11 16:44

Does GLX/EGL work for you in xwayland without llvmpipe CPU fallback? For whatever reason, it doesn't for me, while Vulkan works on the GPU.

yurikoles commented on 2019-05-29 15:00

PRs are welcome: https://github.com/yurikoles-aur/xorg-server-git

zegentz commented on 2019-05-04 19:58

@lordheavy: I've "fixed" this pkg by just modifying the current pkg in the core repos.

https://github.com/ZeGentzy/xorg-server-git

raneon commented on 2018-07-21 10:44

I get the following error when trying to use the pkgbuild of xorg-server-xwayland-git:

==> ERROR: pkgver in provides is not allowed to contain colons, forward slashes, hyphens or whitespace. ==> ERROR:Makepkg could not build xorg-server-git.

zfkerr commented on 2018-05-15 04:04

@lordheavy, I can't build it:

  CC       InitInput.o
  CC       InitOutput.o
  CC       miinitext.o
  CCLD     Xvfb
../../glx/.libs/libglx.a(glxdriswrast.o): In function `__glXDRIscreenProbe':
glxdriswrast.c:(.text+0x72f): undefined reference to `glXGetProcAddressARB'
collect2: error: ld returned 1 exit status
make[3]: *** [Makefile:694: Xvfb] Error 1
make[3]: Leaving directory '/run/mount/user/xorg-server-git/src/xserver/hw/vfb'
make[2]: *** [Makefile:754: all-recursive] Error 1
make[2]: Leaving directory '/run/mount/user/xorg-server-git/src/xserver/hw/vfb'
make[1]: *** [Makefile:615: all-recursive] Error 1
make[1]: Leaving directory '/run/mount/user/xorg-server-git/src/xserver/hw'
make: *** [Makefile:816: all-recursive] Error 1
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build xorg-server-git.

deepsquid commented on 2018-04-08 21:56

xorg-server-xwayland-git is the only package depending on libxfont, as all of the others are depending on libxfont2. Is this normal?