Package Base Details: xorg-server-git

Git Clone URL: https://aur.archlinux.org/xorg-server-git.git (read-only)
Keywords: git x-server xorg xorg-server
Submitter: ilikenwf
Maintainer: yurikoles
Last Packager: yurikoles
Votes: 43
Popularity: 1.234461
First Submitted: 2008-08-07 19:05
Last Updated: 2019-09-01 21:01

Pinned Comments

yurikoles commented on 2019-05-29 15:00

PRs are welcome: https://github.com/yurikoles-aur/xorg-server-git

Latest Comments

« First ‹ Previous ... 7 8 9 10 11 12 13 14 15 16 17 ... Next › Last »

yoseforb commented on 2013-08-27 14:52

Please, add provide 'xwayland'.

NilsBrause commented on 2013-08-22 19:39

@cgx:
Nice catch, thank you! I'll try this out next week when I'm back home. :-)

cgx commented on 2013-08-22 18:18

There seems to be new branch "xwayland" with things happening again

NilsBrause commented on 2013-08-14 17:42

@plfiorini, Portaloffreedom:
Thanks, fixed.

portaloffreedom commented on 2013-08-10 15:46

add bison to makedepends

plfiorini commented on 2013-08-08 14:47

Please add xorg-font-util and inputproto to makedepends.
My advice is to build packages in a chroot to spot this issues.

kelloco2 commented on 2013-07-24 15:18

==> Zaczynam build()
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal --force -I m4
autoreconf: configure.ac: tracing
autoreconf: configure.ac: not using Libtool
autoreconf: running: /usr/bin/autoconf --force
configure.ac:76: error: possibly undefined macro: AC_LIBTOOL_WIN32_DLL
If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.
configure.ac:77: error: possibly undefined macro: AC_DISABLE_STATIC
configure.ac:78: error: possibly undefined macro: AC_PROG_LIBTOOL
autoreconf: /usr/bin/autoconf failed with exit status: 1
==> BŁĄD: Wystąpił błąd w build().
Przerywam...
==> ERROR: Makepkg was unable to build xwayland-git.
;/

Det commented on 2013-07-21 07:25

"git describe --always | cut -d "-" -f3- | tr - ." would work (1.14.99.1.137.g7446989).

Det commented on 2013-07-21 07:23

The default pkgver is wrong (0) and the one you get with "git describe --always | sed 's|-|.|g'" is also wrong (xorg.server.1.14.99.1.137.g7446989).

NilsBrause commented on 2013-07-12 16:58

@postadelmaga:
Thanks, fixed.