Package Base Details: xorg-server-git

Git Clone URL: https://aur.archlinux.org/xorg-server-git.git (read-only)
Keywords: git x-server xorg xorg-server
Submitter: ilikenwf
Maintainer: yurikoles
Last Packager: yurikoles
Votes: 43
Popularity: 1.333861
First Submitted: 2008-08-07 19:05
Last Updated: 2019-09-01 21:01

Pinned Comments

yurikoles commented on 2019-05-29 15:00

PRs are welcome: https://github.com/yurikoles-aur/xorg-server-git

bobpaul commented on 2013-03-22 13:47

So how does one activate this? I've installed this and xf86-video-intel-xwayland-git (modified to depend on wayland and weston instead of wayland-git and weston-git), but when I run weston-launch, I still can't open X11 applications.

From what I can find searching, it sounds like weston is supposed to detect xwayland is installed and load it as a module. Is there a way to force this?

ArcRaven commented on 2013-03-18 23:29

@computerquip:
I have tested your comitted PKGBUILD. Thanks for that!

computerquip commented on 2013-03-11 15:59

My previous comment stated the incorrect branch (probably since it was 2 AM in the morning). The correct branch is "xwayland-1.12". It can be viewed here: http://cgit.freedesktop.org/xorg/xserver/log/?h=xwayland-1.12

computerquip commented on 2013-03-11 08:05

Well, I know that not many have had success with this package.

1. The wrong repo is used. Daniel Stone's repo is out of date. Patches are pushed here (git://anongit.freedesktop.org/xorg/xserver) from branch xserver-1.12

2. It's missing probably a half dozen dependencies (such as fontproto, videoproto, scrnsaverproto, recordproto, libxkbfile, so on).

3. You configure the package prefix to the chroot directory which is probably wrong. This will cause the xserver to look for modules in ${pkgdir}/usr/lib/xorg/modules which is bad since they'll never be found if you use another AUR package or a driver from the official repos. It's also not made obvious unless you happen to come across it in the logs.

Here's a PKGBUILD that I used to get stuff to work. I'd send a screenshot but that seems to be quite difficult in Wayland at the moment...
http://codepad.org/wEaGxfkI

computerquip commented on 2013-03-11 08:05

Well, I know that not many have had success with this package.

1. The wrong repo is used. Daniel Stone's repo is out of date. Patches are pushed here (git://anongit.freedesktop.org/xorg/xserver) from branch xserver-1.12

2. It's missing probably a half dozen dependencies (such as fontproto, videoproto, scrnsaverproto, recordproto, libxkbfile, so on).

3. You configure the package prefix to the chroot directory which is probably wrong. This will cause the xserver to look for modules in ${pkgdir}/usr/lib/xorg/modules which is bad since they'll never be found if you use another AUR package or a driver from the official repos. It's also not made obvious unless you happen to come across it in the logs.

Here's a PKGBUILD that I used to get stuff to work. I'd send a screenshot but that seems to be quite difficult in Wayland at the moment...
http://codepad.org/wEaGxfkI

computerquip commented on 2013-03-11 08:04

Well, I know that not many have had success with this package.

1. The wrong repo is used. Daniel Stone's repo is out of date. Patches are pushed here (git://anongit.freedesktop.org/xorg/xserver) from branch xserver-1.12

2. It's missing probably a half dozen dependencies (such as fontproto, videoproto, scrnsaverproto, recordproto, libxkbfile, so on).

3. You configure the package prefix to the chroot directory which is wrong. This will cause the xserver to look for modules in ${pkgdir}/usr/lib/xorg/modules which is bad since they'll never be found if you use another AUR package or a driver from the official repos. It's also not made obvious unless you happent o come across it in the repositores.

Here's a PKGBUILD that I used to get stuff to work. I'd send a screenshot but that seems to be quite difficult in Wayland at the moment...
http://codepad.org/wEaGxfkI

hwkiller commented on 2013-03-05 04:48

Updated PKGBUILD. You were missing dri2proto, which is necessary for building xf86-video-intel-xwayland-git (otherwise, xwayland-git does not provide dri2.h).

Also notice that I don't have weston-git or wayland-git. Change if you want, but this helped me avoid pulling in all of mesa-full. It's probably not kosher to build a -git without depending on other -gits, but whatever.

http://pastie.org/private/k9ksm375iugucc1bxuwyw

moscar commented on 2013-02-14 19:58

It also depends on xorg-font-util, and glproto is a build dep. ;)

the --prefix= and DESDIR= has not been fixed in the current PKGBUILD.

ArcRaven commented on 2013-02-12 13:35

@moscar:
Done that!

moscar commented on 2013-02-12 13:29

@ArcRaven please look at cl91's comment below. He is right.
You should also be able to remove all the "|| return 1" from the PKGBUILD[1].

[1] https://bbs.archlinux.org/viewtopic.php?pid=1197999#p1197999