Package Base Details: xorg-server-git

Git Clone URL: https://aur.archlinux.org/xorg-server-git.git (read-only)
Keywords: git x-server xorg xorg-server
Submitter: ilikenwf
Maintainer: yurikoles
Last Packager: yurikoles
Votes: 42
Popularity: 0.651857
First Submitted: 2008-08-07 19:05
Last Updated: 2019-09-01 21:01

Pinned Comments

yurikoles commented on 2019-05-29 15:00

PRs are welcome: https://github.com/yurikoles-aur/xorg-server-git

Latest Comments

« First ‹ Previous ... 4 5 6 7 8 9 10 11 12 13 14 ... Next › Last »

Scimmia commented on 2014-04-04 06:06

Pretty well dead now that xwayland has been merged into xserver master.

derekstavis commented on 2014-04-02 17:13

Doesn't even make the package.

In file included from ../include/misc.h:78:0,
from atom.c:55:
/usr/include/X11/Xdefs.h:105:10: error: expected ')' before 'OSTimePtr'

NilsBrause commented on 2014-03-26 11:32

We don't have to worry much longer. :)
https://plus.google.com/+KristianH%C3%B8gsberg/posts/jaehXgvJUg4

NilsBrause commented on 2014-03-15 12:08

@sudsbud:
They're using the old 1.12 branch, that hasn't been updated for ten month.

sudsbud commented on 2014-03-15 00:03

I ended up using a package build from hawaii to get xwayland and that worked - this one would not compile. Maybe they can help? https://github.com/klusark/hawaii-aur/blob/master/xwayland-git/PKGBUILD

Anonymous comment on 2014-03-08 23:40

You'll need fontsproto-git and xporto-git to build this.
https://bugs.freedesktop.org/show_bug.cgi?id=73587

But afer that I get the following error:

hostx.c: In function ‘hostx_init’:
hostx.c:313:9: error: implicit declaration of function ‘ephyr_glamor_connect’ [-Werror=implicit-function-declaration]
HostX.conn = ephyr_glamor_connect();

Anybody got any ideas?

klusark commented on 2014-02-23 00:54

Yukicanis: Often dependencies of actively developed software change, breaking the pkgbuild. If the package doesn't build anymore I'd say it's out-of-date.

NilsBrause commented on 2014-02-18 20:27

Completely revised (make-)deps.

Also please note that there is no need to flag a git package out-of-date. ;)

zanny commented on 2014-02-09 23:19

Missing dependency when building on presentproto.

lifning commented on 2014-02-08 04:39

It seems this needs xcb-util-wm and xcb-util-image as dependencies.