Package Base Details: yaru-remix-git

Git Clone URL: https://aur.archlinux.org/yaru-remix-git.git (read-only, click to copy)
Submitter: doppelhelix
Maintainer: doppelhelix
Last Packager: doppelhelix
Votes: 0
Popularity: 0.000000
First Submitted: 2021-01-12 22:10
Last Updated: 2021-12-03 08:32

Latest Comments

haomingbai commented on 2021-06-06 06:00

有谁知道这是怎么回事?

==> 正在开始 build()... -- The CXX compiler identification is GNU 11.1.0 -- Detecting CXX compiler ABI info -- Detecting CXX compiler ABI info - done -- Check for working CXX compiler: /usr/bin/c++ - skipped -- Detecting CXX compile features -- Detecting CXX compile features - done -- Found X11: /usr/include found components: Xrandr -- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so -- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so - found -- Looking for gethostbyname -- Looking for gethostbyname - found -- Looking for connect -- Looking for connect - found -- Looking for remove -- Looking for remove - found -- Looking for shmat -- Looking for shmat - found -- Looking for IceConnectionNumber in ICE -- Looking for IceConnectionNumber in ICE - found [ 11%] Creating directories for 'singleapplication-populate' [ 22%] Performing download step (git clone) for 'singleapplication-populate' 正克隆到 'singleapplication-src'... fatal: 无法访问 'https://github.com/itay-grudev/SingleApplication/':HTTP/2 stream 1 was not closed cleanly before end of the underlying stream 正克隆到 'singleapplication-src'... fatal: 无法访问 'https://github.com/itay-grudev/SingleApplication/':HTTP/2 stream 1 was not closed cleanly before end of the underlying stream 正克隆到 'singleapplication-src'... error: RPC 失败。curl 16 Error in the HTTP2 framing layer fatal: 在引用列表之后应该有一个 flush 包 -- Had to git clone more than once: 3 times. CMake Error at singleapplication-subbuild/singleapplication-populate-prefix/tmp/singleapplication-populate-gitclone.cmake:31 (message): Failed to clone repository: 'https://github.com/itay-grudev/SingleApplication'

make[2]: [CMakeFiles/singleapplication-populate.dir/build.make:102:singleapplication-populate-prefix/src/singleapplication-populate-stamp/singleapplication-populate-download] 错误 1 make[1]: [CMakeFiles/Makefile2:83:CMakeFiles/singleapplication-populate.dir/all] 错误 2 make: *** [Makefile:91:all] 错误 2

CMake Error at /usr/share/cmake-3.20/Modules/FetchContent.cmake:1012 (message): Build step for singleapplication failed: 2 Call Stack (most recent call first): /usr/share/cmake-3.20/Modules/FetchContent.cmake:1141:EVAL:2 (__FetchContent_directPopulate) /usr/share/cmake-3.20/Modules/FetchContent.cmake:1141 (cmake_language) /usr/share/cmake-3.20/Modules/FetchContent.cmake:1184 (FetchContent_Populate) cmake/ExternalLibraries.cmake:19 (FetchContent_MakeAvailable) CMakeLists.txt:29 (include)

-- Configuring incomplete, errors occurred! See also "/home/haomingbai/.cache/yay/optimus-manager-qt/src/optimus-manager-qt-1.6.3/build/CMakeFiles/CMakeOutput.log". ==> 错误: 在 build() 中发生一个错误。 正在放弃...

求解决方案

doppelhelix commented on 2021-03-27 09:41

gnome40 got released. Back to master-branch

doppelhelix commented on 2021-03-14 09:50

The master-branch is building for Gnome-40 and has no tags. I changed to gnome-3.38 branch for now.

genofire commented on 2021-03-13 21:30

==> Starting pkgver()...
fatal: No tags can describe 'c54b6c45eb1b4cf993f6933255c5274b29d8d66e'.
Try --always, or create some tags.
==> ERROR: pkgver is not allowed to be empty.
==> ERROR: pkgver() generated an invalid version: 
error making: yaru-remix-git (yaru-remix-gnome-shell-theme-git yaru-remix-gtk-theme-git)