Package Base Details: zfs-linux-git

Git Clone URL: https://aur.archlinux.org/zfs-linux-git.git (read-only)
Submitter: demizer
Maintainer: minextu (archzfs-bot)
Last Packager: archzfs-bot
Votes: 23
Popularity: 0.075838
First Submitted: 2016-04-21 08:46
Last Updated: 2019-07-17 09:16

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

severach commented on 2018-04-09 19:10

Why isn't the version in any of the -git packages, and why is the git revision not prefixed with a 'g'?

Neeto commented on 2018-02-19 13:47

Heads up for those using ZFS Encryption; this latest version (2018.02.15.r3313.e921f6508.4.15.3.2-1) may have broken support for mounting ZFS encrypted pools.

Unable to access my desktop pools in the meantime; this issue describes the symptoms https://github.com/zfsonlinux/zfs/issues/7175

EDIT: got around to it a few hours later and downgraded back to 4.14.15.1 kernel and zfs/spl for the time being.

ervinshiznit commented on 2017-12-19 17:42

Thanks. That fixed my issue. And the zfs.target was me reading some old documentation on zfs. Oops

minextu commented on 2017-12-19 10:41

@ervinshiznit You don't need --with-systemd in this package, it's needed in zfs-utils-common-git which already has been updated in the aur (see https://github.com/archzfs/archzfs/issues/214). So just rebuild that.

The zfs-import.target might be a diffeerent issue (https://github.com/archzfs/archzfs/issues/186)

ervinshiznit commented on 2017-12-19 04:39

Perhaps I'm just being dense, but I downloaded the snapshot, edited the PKGBUILD file so that lines 37 and 38 are now

--with-linux-obj=/usr/lib/modules/4.14.6-1-ARCH/build \

--with-systemd

But I still don't have zfs.target available as a systemd.

What am I doing wrong?

ArnoW commented on 2017-12-18 22:09

Thanks for your -very- quick response!

demizer commented on 2017-12-18 22:05

Here it is: https://github.com/archzfs/archzfs/pull/213

demizer commented on 2017-12-18 22:01

I do see the systmed scripts are missing in the zfs-utils-common-git packages. I will fix and update.

ArnoW commented on 2017-12-18 21:50

After updating to zfs-linux-git 2017.12.18.r3214.bbffb59ef.4.14.6.1-1 the systemd services for zfs are gone. Is there a bug in the package or am I missing something?

lockheed commented on 2017-09-27 17:49

Why is it that this git package has version 0.7.0, while the "stable" non-git zfs-linux is 0.7.2?
Wasn't git version supposed to be newer than the mainline?