summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThe3DmaN2020-11-23 19:50:59 -0600
committerThe3DmaN2020-11-23 19:50:59 -0600
commitbc5995026cfecc69bb76b84e1b2e3eb4036c5846 (patch)
tree717d446d9a91c18bacea99d0aa23827a8d03e88c
downloadaur-bc5995026cfecc69bb76b84e1b2e3eb4036c5846.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD27
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a4cca599bcf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = abv-calc-git
+ pkgdesc = ABV Calculator for Refractometers
+ pkgver = 1.1.r55.3033227
+ pkgrel = 1
+ url = https://gitlab.com/The3DmaN/abv-calc
+ arch = any
+ license = GPL3
+ depends = git
+ depends = python>=3.8
+ depends = python-setuptools
+ depends = python-pyqt5
+ depends = qt5-svg
+ depends = python-requests
+ provides = abv-calc
+ conflicts = abv-calc
+ source = git+https://gitlab.com/The3DmaN/abv-calc.git
+ md5sums = SKIP
+
+pkgname = abv-calc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a76a71a29ffa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: The3DmaN <the3dman dot appdev at protonmail dot com>
+
+pkgname=abv-calc-git
+pkgver=1.1.r55.3033227
+pkgrel=1
+pkgdesc="ABV Calculator for Refractometers"
+arch=("any")
+url="https://gitlab.com/The3DmaN/${pkgname%-git}"
+license=("GPL3")
+depends=("git" "python>=3.8" "python-setuptools" "python-pyqt5" "qt5-svg" "python-requests")
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+https://gitlab.com/The3DmaN/${pkgname%-git}.git")
+md5sums=("SKIP")
+
+pkgver()
+{
+ cd "${pkgname%-git}"
+ printf "1.1.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package()
+{
+ cd "${pkgname%-git}"
+ python setup.py install --optimize="1" --root="$pkgdir"
+}
+