summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052025-03-12 16:27:44 +0800
committerzxp198210052025-03-12 16:27:44 +0800
commitb9086596d22a27b92da9b1703d58250e5ba0ca15 (patch)
tree15503a28290d549d07389dae544d7f0e4ee73d9c
downloadaur-b9086596d22a27b92da9b1703d58250e5ba0ca15.tar.gz
update to 3.8.2
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD51
-rw-r--r--catalystplus-desktop.sh29
3 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c83f8116cde3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = catalystplus-desktop-bin
+ pkgdesc = A multi-terminal and interoperable scientific research professional information aggregation platform client to improve the efficiency of researchers' access to the latest research results in the field.(Prebuilt version.Use system-wide electron)
+ pkgver = 3.8.2
+ pkgrel = 1
+ url = https://www.researchercosmos.com/
+ arch = x86_64
+ license = MIT
+ makedepends = fuse2
+ depends = electron22
+ provides = catalystplus-desktop=3.8.2
+ conflicts = catalystplus-desktop
+ source = catalystplus-desktop-3.8.2.AppImage::https://assets.catalystplus.cn/CatalystPlusDesktopPackage/linux/%E5%82%AC%E5%8C%96%E5%89%82%E5%8A%A0%20CatalystPlus-3.8.2.AppImage
+ source = LICENSE.html::https://www.researchercosmos.com/docs/terms
+ source = catalystplus-desktop.sh
+ sha256sums = 23d70f8d388abd9ab24b8ebd90a8dacfbb94d29d3addb791842945a390ee262d
+ sha256sums = b56c7e5caa0e331d5fa168c2455c8105bb67f69b6ee4808fd9faac85f49430fd
+ sha256sums = 291f50480f5a61bc9c68db7d44cd0412071128706baa868a9cb854f8779a1980
+
+pkgname = catalystplus-desktop-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..348c44422fd2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=catalystplus-desktop-bin
+_pkgname=CatalystPlus
+pkgver=3.8.2
+_electronversion=22
+pkgrel=1
+pkgdesc="A multi-terminal and interoperable scientific research professional information aggregation platform client to improve the efficiency of researchers' access to the latest research results in the field.(Prebuilt version.Use system-wide electron)"
+arch=('x86_64')
+url="https://www.researchercosmos.com/"
+license=('MIT')
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
+depends=(
+ "electron${_electronversion}"
+)
+makedepends=(
+ 'fuse2'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.AppImage::https://assets.catalystplus.cn/CatalystPlusDesktopPackage/linux/%E5%82%AC%E5%8C%96%E5%89%82%E5%8A%A0%20${_pkgname}-${pkgver}.AppImage"
+ "LICENSE.html::https://www.researchercosmos.com/docs/terms"
+ "${pkgname%-bin}.sh"
+)
+sha256sums=('23d70f8d388abd9ab24b8ebd90a8dacfbb94d29d3addb791842945a390ee262d'
+ 'b56c7e5caa0e331d5fa168c2455c8105bb67f69b6ee4808fd9faac85f49430fd'
+ '291f50480f5a61bc9c68db7d44cd0412071128706baa868a9cb854f8779a1980')
+prepare() {
+ sed -i -e "
+ s/@electronversion@/${_electronversion}/g
+ s/@appname@/${pkgname%-bin}/g
+ s/@runname@/app.asar/g
+ s/@cfgdirname@/${pkgname%-bin}/g
+ s/@options@//g
+ " "${srcdir}/${pkgname%-bin}.sh"
+ chmod +x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
+ "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
+ sed -i "s/AppRun --no-sandbox/${pkgname%-bin}/g" "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ find "${srcdir}/squashfs-root/resources" -type d -exec chmod 755 {} +
+}
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ cp -Pr --no-preserve=ownership "${srcdir}/squashfs-root/resources/app.asar.unpacked" "${pkgdir}/usr/lib/${pkgname%-bin}"
+ _icon_sizes=(16x16 32x32 48x48 64x64 128x128 256x256 512x512 1024x1024)
+ for _icons in "${_icon_sizes[@]}";do
+ install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
+ -t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
+ done
+ install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ install -Dm644 "${srcdir}/LICENSE.html" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+} \ No newline at end of file
diff --git a/catalystplus-desktop.sh b/catalystplus-desktop.sh
new file mode 100644
index 000000000000..40e422ca2ee7
--- /dev/null
+++ b/catalystplus-desktop.sh
@@ -0,0 +1,29 @@
+#!/bin/bash
+set -o pipefail
+_APPDIR="/usr/lib/@appname@"
+_RUNNAME="${_APPDIR}/@runname@"
+_CFGDIR="@cfgdirname@/"
+_OPTIONS="@options@"
+export PATH="${_APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
+export ELECTRON_DISABLE_SECURITY_WARNINGS=true
+export ELECTRON_OVERRIDE_DIST_PATH="/usr/bin/electron@electronversion@"
+export NODE_ENV=production
+export XDG_CONFIG_HOME="${XDG_CONFIG_HOME:-$HOME/.config}"
+export _FLAGS_FILE="${XDG_CONFIG_HOME}/${_CFGDIR}@appname@-flags.conf"
+declare -a _USER_FLAGS
+if [[ -f "${_FLAGS_FILE}" ]]; then
+ while read -r line; do
+ if [[ ! "${line}" =~ ^[[:space:]]*#.* ]]; then
+ _USER_FLAGS+=("${line}")
+ fi
+ done < "${_FLAGS_FILE}"
+fi
+cd "${_APPDIR}" || { echo "Failed to change directory to ${_APPDIR}"; exit 1; }
+if [[ "${EUID}" -ne 0 ]] || [[ "${ELECTRON_RUN_AS_NODE}" ]]; then
+ exec electron@electronversion@ "${_RUNNAME}" ${_OPTIONS} "${_USER_FLAGS[@]}" "$@"
+else
+ exec electron@electronversion@ "${_RUNNAME}" ${_OPTIONS} --no-sandbox "${_USER_FLAGS[@]}" "$@"
+fi \ No newline at end of file