summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrayden Banks2018-09-06 00:26:46 -0700
committerBrayden Banks2018-09-06 00:26:46 -0700
commit63d113c758613ece265f00091426611b42fe55a1 (patch)
tree919d6d54d4b6c55ffc1393e7758da8353cf93eb1
downloadaur-63d113c758613ece265f00091426611b42fe55a1.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--LICENSE20
-rw-r--r--PKGBUILD30
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..503d208306f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = fediplay-git
+ pkgdesc = A Mastodon client that automatically plays your friends' music (Git version)
+ pkgver = r56.1f18295
+ pkgrel = 1
+ url = https://github.com/zigg/fediplay
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-setuptools
+ depends = ffmpeg
+ depends = python
+ depends = python-appdirs
+ depends = python-click
+ depends = python-cssselect
+ depends = python-dotenv
+ depends = python-lxml
+ depends = python-mastodon
+ depends = youtube-dl
+ source = git+https://github.com/zigg/fediplay
+ source = LICENSE
+ sha256sums = SKIP
+ sha256sums = 37598db0448cfa858461cfa4d36a17b39dcb45ea7957e4dc81cdbddd0ef6cdc3
+
+pkgname = fediplay-git
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..e539c65f881b
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,20 @@
+Copyright (c) 2017 Matt Behrens.
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4e7eccd699b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: bb010g <me@bb010g.com>
+pkgname=fediplay-git
+pkgver=r56.1f18295
+pkgrel=1
+pkgdesc="A Mastodon client that automatically plays your friends' music (Git version)"
+arch=(any)
+url="https://github.com/zigg/${pkgname%-git}"
+license=('MIT')
+depends=(ffmpeg python python-{appdirs,click,cssselect,dotenv,lxml,mastodon} youtube-dl)
+makedepends=(git python-setuptools)
+source=("git+https://github.com/zigg/${pkgname%-git}"
+ "LICENSE")
+sha256sums=('SKIP'
+ '37598db0448cfa858461cfa4d36a17b39dcb45ea7957e4dc81cdbddd0ef6cdc3')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}