summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikhil Singh2023-02-27 18:58:39 +0530
committerNikhil Singh2023-02-27 18:58:39 +0530
commit580e3c778896de5a3cfc686e668c59e2829bd90f (patch)
tree512990d94e625d5f698fd8c7b167dc5b0889842d
downloadaur-580e3c778896de5a3cfc686e668c59e2829bd90f.tar.gz
Initial Commit
- Added PKGBUILD - Added .SRCINFO
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8fd09f8019b1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = hyprland-scratchpad-git
+ pkgdesc = A helper for scratchpads within Hyprland.
+ pkgver = r34.c19c544
+ pkgrel = 1
+ url = https://github.com/hyprwm/contrib
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = hyprland
+ depends = jq
+ optdepends = libnotify: Notify users on an action.
+ provides = scratchpad
+ conflicts = scratchpad
+ source = git+https://github.com/hyprwm/contrib.git
+ md5sums = SKIP
+
+pkgname = hyprland-scratchpad-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..899922d357d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Nikhil Singh <nik.singh710@gmail.com>
+
+pkgname=hyprland-scratchpad-git
+pkgver=814e260
+pkgrel=1
+pkgdesc="A helper for scratchpads within Hyprland."
+arch=("any")
+url="https://github.com/hyprwm/contrib"
+license=('MIT')
+provides=('scratchpad')
+conflicts=('scratchpad')
+depends=("hyprland" "jq")
+optdepends=('libnotify: Notify users on an action.')
+makedepends=("git")
+source=("git+https://github.com/hyprwm/contrib.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/contrib/scratchpad"
+ git log --pretty="format:%h" -n 1 scratchpad | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/contrib/scratchpad"
+
+ install -Dm 755 scratchpad "$pkgdir/usr/bin/scratchpad"
+}