summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2016-04-03 09:01:27 +0200
committerMichel Zou2016-04-03 09:01:27 +0200
commit4eba89189717fa4acb8f90f46aaa4b2e73d49cf5 (patch)
tree8611138c5a7c6927bcf81c4b6a42a9fd1e580bd7
downloadaur-4eba89189717fa4acb8f90f46aaa4b2e73d49cf5.tar.gz
1.2rc3
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec8bc01a91f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Apr 3 07:01:27 UTC 2016
+pkgbase = mingw-w64-speexdsp
+ pkgdesc = DSP library derived from Speex (mingw-w64)
+ pkgver = 1.2rc3
+ pkgrel = 1
+ url = http://www.speexdsp.org
+ arch = any
+ license = BSD
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-crt
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = http://downloads.us.xiph.org/releases/speex/speexdsp-1.2rc3.tar.gz
+ md5sums = 70d9d31184f7eb761192fd1ef0b73333
+
+pkgname = mingw-w64-speexdsp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3eaaf3dc7b8c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+pkgname=mingw-w64-speexdsp
+pkgver=1.2rc3
+pkgrel=1
+pkgdesc="DSP library derived from Speex (mingw-w64)"
+arch=(any)
+url="http://www.speexdsp.org"
+license=("BSD")
+makedepends=('mingw-w64-configure')
+depends=('mingw-w64-crt')
+options=('staticlibs' '!strip' '!buildflags')
+source=("http://downloads.us.xiph.org/releases/speex/speexdsp-$pkgver.tar.gz")
+md5sums=('70d9d31184f7eb761192fd1ef0b73333')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "${srcdir}"/speexdsp-${pkgver}
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/speexdsp-${pkgver}/build-${_arch}"
+ make DESTDIR="$pkgdir" install
+ rm -r "$pkgdir"/usr/${_arch}/share
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}