summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpingplug2025-02-23 14:55:48 +0800
committerpingplug2025-02-23 14:55:48 +0800
commitb488fb91b87784c20d1691ca4983d834372fc814 (patch)
tree2c011b49aa5fbc427ee314a1483903ebf50ffa78
parent3e59b3959102e28b1367b4bfabfb224ec31c43b7 (diff)
downloadaur-b488fb91b87784c20d1691ca4983d834372fc814.tar.gz
update to 5.6.4
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 78b35bd419f5..692dccb548d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-xz
pkgdesc = Library and command line tools for XZ and LZMA compressed files (mingw-w64)
- pkgver = 5.6.3
+ pkgver = 5.6.4
pkgrel = 1
url = https://tukaani.org/xz/
arch = any
@@ -15,8 +15,8 @@ pkgbase = mingw-w64-xz
options = !strip
options = staticlibs
options = !buildflags
- source = git+https://github.com/tukaani-project/xz#tag=v5.6.3
+ source = git+https://github.com/tukaani-project/xz#tag=v5.6.4
validpgpkeys = 3690C240CE51B4670D30AD1C38EE757D69184620
- b2sums = 3e286713a415b5d7ddd95698b511c71822a064059e8cb7084c77da72d9e46b9b01ac7f037b8a80f973480f191245c62d055c02739a152ef10b6d9c66b2923cca
+ b2sums = 264604298ee025ef01ec0439b6a339f25f4b18131b3f222eca2764df98bb41de5a22439b91349760b436b2ded31c132983cdcb277ec54b0097dd51063b4c0cd8
pkgname = mingw-w64-xz
diff --git a/PKGBUILD b/PKGBUILD
index 5e2bab3c2262..6f942b13dbea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _pkgname=xz
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
pkgname=mingw-w64-xz
-pkgver=5.6.3
+pkgver=5.6.4
pkgrel=1
pkgdesc="Library and command line tools for XZ and LZMA compressed files (mingw-w64)"
arch=('any')
@@ -17,19 +17,20 @@ makedepends=('mingw-w64-configure' 'git' 'po4a' 'doxygen')
options=('!strip' 'staticlibs' '!buildflags')
validpgpkeys=('3690C240CE51B4670D30AD1C38EE757D69184620') # Lasse Collin <lasse.collin@tukaani.org>
source=("git+https://github.com/tukaani-project/xz#tag=v${pkgver}")
-b2sums=('3e286713a415b5d7ddd95698b511c71822a064059e8cb7084c77da72d9e46b9b01ac7f037b8a80f973480f191245c62d055c02739a152ef10b6d9c66b2923cca')
+b2sums=('264604298ee025ef01ec0439b6a339f25f4b18131b3f222eca2764df98bb41de5a22439b91349760b436b2ded31c132983cdcb277ec54b0097dd51063b4c0cd8')
prepare() {
cd "${srcdir}/${_pkgname}"
- ./autogen.sh
+ PATH=/usr/bin/vendor_perl:${PATH} ./autogen.sh
}
build() {
cd "${srcdir}/${_pkgname}"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-configure
+ ${_arch}-configure \
+ --disable-nls
make
popd
done