summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2025-04-17 16:47:32 +0700
committerKonstantin Shalygin2025-04-17 16:47:32 +0700
commit9aa58bd014c2f603305c3a28720db4da1ff79ff1 (patch)
tree45c0b5c06d9c5b0ae386fcffaabaa370c87e0704
downloadaur-9aa58bd014c2f603305c3a28720db4da1ff79ff1.tar.gz
Port netconsole from RedHat to Archlinux
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD25
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f289f2ac145c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = netconsole
+ pkgdesc = Service for initializing of network console logging
+ pkgver = 10.26
+ pkgrel = 1
+ url = https://github.com/fedora-sysv/initscripts
+ arch = any
+ license = GPL2
+ depends = sed
+ depends = iproute2
+ depends = iputils
+ depends = util-linux
+ conflicts = systemd-netconsole
+ backup = etc/sysconfig/netconsole
+ source = https://github.com/fedora-sysv/initscripts/archive/refs/tags/10.26.tar.gz
+ sha256sums = cac382a2cc7644243db00e848d2334646520b88c10e841727dee42c726da21c4
+
+pkgname = netconsole
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7c6927b4669a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/*
+src/*
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb3c84890c35
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Shalygin Konstantin <k0ste@k0ste.ru>
+# Contributor: Shalygin Konstantin <k0ste@k0ste.ru>
+
+pkgbase='netconsole'
+pkgname="${pkgbase}"
+_pkgname='initscripts'
+pkgver='10.26'
+pkgrel='1'
+pkgdesc='Service for initializing of network console logging'
+arch=('any')
+url="https://github.com/fedora-sysv/${_pkgname}"
+license=('GPL2')
+depends=('sed' 'iproute2' 'iputils' 'util-linux' 'kmod')
+conflicts=("systemd-${pkgname}")
+source=("${url}/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('cac382a2cc7644243db00e848d2334646520b88c10e841727dee42c726da21c4')
+backup=("etc/sysconfig/${pkgname}")
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ install -Dm0644 "etc/sysconfig/${pkgname}" -t "${pkgdir}/etc/sysconfig"
+ install -Dm0644 "etc/rc.d/init.d/functions" -t "${pkgdir}/etc/rc.d/init.d"
+ install -Dm0775 "usr/libexec/${pkgname}" -t "${pkgdir}/usr/libexec"
+ install -Dm0644 "usr/lib/systemd/system/${pkgname}.service" -t "${pkgdir}/usr/lib/systemd/system"
+}