summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgilcu32024-12-18 15:56:36 +0100
committergilcu32024-12-18 15:56:36 +0100
commit38386c6305b81214995f4362e6942b2aa15acaf5 (patch)
tree86b3bfb59f08f87f00a02d5d57ab108c83a1a1b9
parentf9df024474414736655ad39681a7f1090a48a0eb (diff)
downloadaur-38386c6305b81214995f4362e6942b2aa15acaf5.tar.gz
upgpkg: python-daemon 3.1.2-2
fix check, thx @carsme
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d81ada5ea81..1655b05a635a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-daemon
pkgdesc = Library to implement a well-behaved Unix daemon process
pkgver = 3.1.2
- pkgrel = 1
+ pkgrel = 2
url = https://pagure.io/python-daemon/
arch = any
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index 26e39f881aed..9bc0c7ce0a0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=python-daemon
pkgver=3.1.2
-pkgrel=1
+pkgrel=2
pkgdesc='Library to implement a well-behaved Unix daemon process'
arch=('any')
url='https://pagure.io/python-daemon/'
@@ -27,6 +27,10 @@ build() {
check() {
cd ${pkgname//-/_}-$pkgver
+ rm -rf tmp_install
+ python -m installer --destdir=tmp_install dist/*.whl
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ export PYTHONPATH="$PWD/tmp_install/$site_packages"
python -m unittest discover -v
}