summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bershatsky2024-08-17 20:00:38 +0300
committerDaniel Bershatsky2024-08-17 20:00:40 +0300
commita46d2035f53e7edcea45922280b953a2044aa592 (patch)
treef342b2e168d961af6ebc1222666261823990b691
parent2756d30f725aa261621cfd33b99e8844694b5baa (diff)
downloadaur-a46d2035f53e7edcea45922280b953a2044aa592.tar.gz
upgpkg: 18.0.0-2
Exclude a copy of `libHalide.so` from wheel with suitable CMake option.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6d79929322c..37ca617e4bb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = python-halide
pkgdesc = A Python interface for Halide language.
pkgver = 18.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/halide/Halide
arch = x86_64
license = MIT
makedepends = cmake
- makedepends = halide
makedepends = ninja
makedepends = python-build
makedepends = python-installer
makedepends = python-setuptools
makedepends = python-scikit-build
makedepends = python-wheel
+ depends = halide
depends = python-imageio
depends = python-numpy
depends = python-pillow
diff --git a/PKGBUILD b/PKGBUILD
index 91cfe962c557..0c2d48f039bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,16 @@
pkgname=python-halide
_pkgname=${pkgname#python-}
pkgver=18.0.0
-pkgrel=1
+pkgrel=2
pkgdesc='A Python interface for Halide language.'
arch=('x86_64')
url='https://github.com/halide/Halide'
license=('MIT')
groups=()
-depends=('python-imageio' 'python-numpy' 'python-pillow' 'python-scipy')
+depends=('halide' 'python-imageio' 'python-numpy' 'python-pillow' 'python-scipy')
makedepends=(
- 'cmake' 'halide' 'ninja' 'python-build' 'python-installer'
- 'python-setuptools' 'python-scikit-build' 'python-wheel'
+ 'cmake' 'ninja' 'python-build' 'python-installer' 'python-setuptools'
+ 'python-scikit-build' 'python-wheel'
)
optdepends=()
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
@@ -20,6 +20,7 @@ sha256sums=('1176b42a3e2374ab38555d9316c78e39b157044b5a8e765c748bf3afd2edb351')
prepare() {
sed -Ei '/"cmake|ninja|pybind11/d' $srcdir/${_pkgname^}-$pkgver/pyproject.toml
+ sed -i 's/-DHalide_Python_INSTALL_IMPORTED_DEPS=ON/-DHalide_Python_INSTALL_IMPORTED_DEPS=OFF/' $srcdir/${_pkgname^}-$pkgver/setup.py
}
build() {