summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo Mao2021-04-19 22:20:54 +0800
committerLeo Mao2021-04-19 22:20:54 +0800
commite0108cdc42c606798cab7d4da9e11664d90a5a97 (patch)
treec7902e64bcebaad739a447d6c6ded12b736cdd21
parent146c60fa0a97f2e4018fbab5835b268e1f490a2f (diff)
downloadaur-e0108cdc42c606798cab7d4da9e11664d90a5a97.tar.gz
upgpkg: python-torchaudio-git r824.5cca0008-1
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0b0992957db..bec11c620a76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-torchaudio-git
pkgdesc = Data manipulation and transformation for audio signal processing, powered by PyTorch
- pkgver = r762.7b85f1c3
+ pkgver = r824.5cca0008
pkgrel = 1
url = https://github.com/pytorch/audio
arch = x86_64
@@ -13,6 +13,7 @@ pkgbase = python-torchaudio-git
depends = sox
depends = python-pytorch
optdepends = python-kaldi-io
+ optdepends = python-soundfile
provides = python-torchaudio
conflicts = python-torchaudio
source = git+https://github.com/pytorch/audio
diff --git a/PKGBUILD b/PKGBUILD
index 3abc1bb51658..b8caedff46f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Leo Mao <leomaoyw at gmail dot com>
pkgname=python-torchaudio-git
_pkgname=audio
-pkgver=r762.7b85f1c3
+pkgver=r824.5cca0008
pkgrel=1
pkgdesc="Data manipulation and transformation for audio signal processing, powered by PyTorch"
arch=('x86_64')
url="https://github.com/pytorch/audio"
license=('BSD')
depends=('python' 'sox' 'python-pytorch')
-optdepends=('python-kaldi-io')
+optdepends=('python-kaldi-io' 'python-soundfile')
makedepends=('git' 'python-setuptools' 'cmake' 'ninja')
provides=('python-torchaudio')
conflicts=('python-torchaudio')
@@ -35,6 +35,8 @@ prepare() {
build() {
msg "Building Python 3"
cd "${srcdir}/${_pkgname}"
+ CUDA_HOME=/opt/cuda \
+ BUILD_SOX=1 \
python setup.py build
}