summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 09:52:45 +0800
committerSukanka2022-06-06 09:52:45 +0800
commitb768c747d9bf815a977ca082b09801eae1470b4a (patch)
treea3fbec4f4ea94a9bf4ec46b1bf58130c83d62338
downloadaur-b768c747d9bf815a977ca082b09801eae1470b4a.tar.gz
add r-flowclust
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD45
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..54cb13b9c750
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = r-flowclust
+ pkgdesc = Clustering for Flow Cytometry
+ pkgver = 3.34.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/flowClust
+ arch = x86_64
+ license = Artistic2.0
+ depends = r
+ depends = r-biobase
+ depends = r-biocgenerics
+ depends = r-clue
+ depends = r-corpcor
+ depends = r-ellipse
+ depends = r-flowcore
+ depends = r-flowviz
+ depends = r-graph
+ depends = r-mnormt
+ depends = make
+ optdepends = r-flowworkspace
+ optdepends = r-flowworkspacedata
+ optdepends = r-knitr
+ optdepends = r-opencyto
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/flowClust_3.34.0.tar.gz
+ sha256sums = 93aeb50d3fd5c3fa3c9951496e639e0bf17cff8d13cb0bed1749418574aabb14
+
+pkgname = r-flowclust
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1af4fd59e62e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# system requirements: GNU make
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=flowClust
+_pkgver=3.34.0
+pkgname=r-${_pkgname,,}
+pkgver=3.34.0
+pkgrel=1
+pkgdesc='Clustering for Flow Cytometry'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-biobase
+ r-biocgenerics
+ r-clue
+ r-corpcor
+ r-ellipse
+ r-flowcore
+ r-flowviz
+ r-graph
+ r-mnormt
+ make
+)
+optdepends=(
+ r-flowworkspace
+ r-flowworkspacedata
+ r-knitr
+ r-opencyto
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('93aeb50d3fd5c3fa3c9951496e639e0bf17cff8d13cb0bed1749418574aabb14')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: