summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneon_arch2023-10-01 23:40:39 +0300
committerneon_arch2023-10-01 23:40:39 +0300
commit5431997e4b63d88f568be56ca4988c73382d7679 (patch)
treef80dbce7d8802aabe96a470965b2a5387e1dac4c
parent0481641764f10ac8f94d1f123f94ada086a61756 (diff)
downloadaur-5431997e4b63d88f568be56ca4988c73382d7679.tar.gz
🚀 chore: updating the pkgbuild
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a417ed55bae..e9f7c0be736e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = websurfx-git
pkgdesc = An open-source alternative to Searx that provides clean, ad-free, and organic results with incredible speed while keeping privacy and security in mind.
- pkgver = 0.6.0.r115.35f709f
+ pkgver = v1.0.0.r0.gca30fd5
pkgrel = 1
- url = https://github.com/neon-mmd/websurfx.git
+ url = https://github.com/neon-mmd/websurfx
install = websurfx-git.install
arch = x86_64
license = AGPL3
makedepends = git
depends = rustup
depends = cargo
- depends = redis
+ depends = luajit
+ optdepends = redis: A redis cache server for distributed caching
provides = websurfx-git
conflicts = websurfx-edge-git
- source = git+https://github.com/neon-mmd/websurfx.git
+ source = git+https://github.com/neon-mmd/websurfx
md5sums = SKIP
pkgname = websurfx-git
diff --git a/PKGBUILD b/PKGBUILD
index 03fa4e1e017a..69bd7f36a836 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: pkg_maintainer <archlinuxpackagemaintainer@gmail.com>
pkgname=websurfx-git
-pkgver=0.6.0.r115.35f709f
+pkgver=v1.0.0.r0.gca30fd5
pkgrel=1
epoch=
pkgdesc="An open-source alternative to Searx that provides clean, ad-free, and organic results with incredible speed while keeping privacy and security in mind."
arch=('x86_64')
-url="https://github.com/neon-mmd/websurfx.git"
+url="https://github.com/neon-mmd/websurfx"
license=('AGPL3')
groups=()
-depends=(rustup cargo redis)
+depends=(rustup cargo luajit)
makedepends=(git)
checkdepends=()
-optdepends=()
+optdepends=('redis: A redis cache server for distributed caching')
provides=(websurfx-git)
conflicts=(websurfx-edge-git)
replaces=()
@@ -25,8 +25,9 @@ md5sums=('SKIP')
validpgpkeys=()
pkgver() {
- cd websurfx
- printf "0.6.0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd websurfx
+ git checkout stable
+ git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
@@ -42,6 +43,8 @@ package() {
cp -rf public/ ${pkgdir}/opt/websurfx/public/
install -Dm755 target/release/websurfx "${pkgdir}/usr/bin/websurfx"
install -Dm644 websurfx/config.lua "${pkgdir}/etc/xdg/websurfx/config.lua"
+ install -Dm644 websurfx/allowlist.txt "${pkgdir}/etc/xdg/websurfx/allowlist.txt"
+ install -Dm644 websurfx/blocklist.txt "${pkgdir}/etc/xdg/websurfx/blocklist.txt"
install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}