summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrederic Bezies2024-05-19 18:37:06 +0200
committerFrederic Bezies2024-05-19 18:37:06 +0200
commitcda607714204b1235ea0229b34a9f15af8f8c3ed (patch)
tree001a7a47968e1da9f8aa5bf7aa2a969753f248b5 /PKGBUILD
parent64a20045bf5faa13ab56211ba03c260e3b80cfb5 (diff)
downloadaur-dosbox-x-sdl2.tar.gz
Workaround a bug in gcc 13.x+
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0413824ac87e..4af34883f01c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=dosbox-x-sdl2
_pkgname=dosbox-x
pkgver=2024.03.01
-pkgrel=4
+pkgrel=5
pkgdesc="x86 emulator with builtin DOS, with patches and more features"
arch=(i686 x86_64 aarch64)
url="http://dosbox-x.com"
@@ -18,6 +18,13 @@ options=(!debug)
build() {
cd "$srcdir/dosbox-x-dosbox-x-v$pkgver"
+
+ # Workaround a bug in gcc 13.x+ grabbed from dosbox-x AUR PKGBUILD
+
+ export CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fexceptions \
+ -Wp,-D_FORTIFY_SOURCE=2 -Wformat \
+ -fstack-clash-protection -fcf-protection"
+ export CXXFLAGS="$CFLAGS -Wp,-D_GLIBCXX_ASSERTIONS"
./autogen.sh
./configure --enable-debug --enable-avcodec --prefix=/usr --enable-sdl2