summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxiota2024-05-18 08:05:23 +0000
committerxiota2024-05-18 08:05:23 +0000
commit6aaec8394ef1c5befb2401e64d3565470b870e9f (patch)
treefafb069317bfd0587cfc6b565f812a1ab62e3714 /PKGBUILD
parent2bf965cb97ff557e7566ff113100e866c6a57394 (diff)
downloadaur-midori.tar.gz
11.3.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 22 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a5a0a8e4a40..23fd39ce8af0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
## basic info
_pkgname="midori"
pkgname="$_pkgname"
-pkgver=11.3.2
+pkgver=11.3.3
pkgrel=1
pkgdesc="Web browser based on Floorp"
url="https://github.com/goastian/midori-desktop"
@@ -55,7 +55,7 @@ makedepends=(
nodejs
python
python-setuptools
- rust
+ rustup
unzip
wasi-compiler-rt
wasi-libc
@@ -97,18 +97,28 @@ options=(
: ${_lssver:=v2022.10.12}
noextract=("lss-${_lssver}.tar.gz")
+_patch_commit="24a6ea8"
+
_pkgsrc="midori-tensei"
source=(
"$_pkgsrc"::"git+https://github.com/goastian/midori-desktop.git#tag=v$pkgver"
"goastian.l10n-central"::"git+https://github.com/goastian/l10n-central.git"
"lss-${_lssver}.tar.gz"::"https://chromium.googlesource.com/linux-syscall-support/+archive/refs/tags/${_lssver}.tar.gz"
"$_pkgname.desktop"
+
+ "18d19413472f-$_patch_commit.patch"::"https://aur.archlinux.org/cgit/aur.git/plain/18d19413472f.patch?h=firefox-esr&id=$_patch_commit"
+ "6af7194e2778-$_patch_commit.patch"::"https://aur.archlinux.org/cgit/aur.git/plain/6af7194e2778.patch?h=firefox-esr&id=$_patch_commit"
+ "b1cc62489fae-$_patch_commit.patch"::"https://aur.archlinux.org/cgit/aur.git/plain/b1cc62489fae.patch?h=firefox-esr&id=$_patch_commit"
)
sha256sums=(
'SKIP'
'SKIP'
'SKIP'
'7ef0f85f2b111caa08a3e855cb4b6595b6d0f62b3de13ce59eea94a580eec470'
+
+ '3cc55401ed5e027f1b9e667b0b52296af11f3c5c62b4a80b7e55cda0e117ed18'
+ '6952f93889acb514e3b06e251ea901df88c39b429da9677cd5547d90a8b6c73e'
+ 'f66a944fa8804c16b1f7bd9b42b18bfc2552a891adc148085f4b91685e8db117'
)
prepare() {
@@ -221,11 +231,17 @@ export CXX='clang++'
export NM=llvm-nm
export RANLIB=llvm-ranlib
END
+
+ patch -Np1 -F100 -i "$srcdir/18d19413472f-$_patch_commit.patch"
+ patch -Np1 -F100 -i "$srcdir/6af7194e2778-$_patch_commit.patch"
+ patch -Np1 -F100 -i "$srcdir/b1cc62489fae-$_patch_commit.patch"
}
build() {
cd "$_pkgsrc"
+ export RUSTUP_TOOLCHAIN=1.77
+
export XDG_RUNTIME_DIR="${XDG_RUNTIME_DIR:-$srcdir/xdg-runtime}"
[ ! -d "$XDG_RUNTIME_DIR" ] && install -dm700 "${XDG_RUNTIME_DIR:?}"
@@ -236,6 +252,10 @@ build() {
export MOZ_BUILD_DATE="$(date -u${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH} +%Y%m%d%H%M%S)"
export MOZ_NOSPAM=1
+ # malloc_usable_size is used in various parts of the codebase
+ CFLAGS="${CFLAGS/_FORTIFY_SOURCE=3/_FORTIFY_SOURCE=2}"
+ CXXFLAGS="${CXXFLAGS/_FORTIFY_SOURCE=3/_FORTIFY_SOURCE=2}"
+
# LTO/PGO needs more open files
ulimit -n 4096