summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThe one with the braid2024-05-10 21:12:54 +0200
committerThe one with the braid2024-05-10 21:12:54 +0200
commit9b7a303f3185acafd61c0ec9ce110b7562696ccd (patch)
tree84b995c0d01d36ba81cbfcd7bdc2d44a8b14ec45 /PKGBUILD
parentb80bb6402b51fbf1c1050536dae9d344db2eb6b3 (diff)
downloadaur-openssl-static.tar.gz
chore: bump version
Signed-off-by: The one with the braid <info@braid.business>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2b4c26de32bf..ebfec694442b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
-# Maintainer: Robert Falkenberg <robert.falkenberg@srs.io>
+# Maintainer: The one with the braid <info@braid.business>
+# Contributor: Robert Falkenberg <robert.falkenberg@srs.io>
# Contributor: Pierre Schmitz <pierre@archlinux.de>
pkgname=openssl-static
_pkgname=openssl
-_ver=3.1.2
+_ver=3.3.0
# use a pacman compatible version scheme
pkgver=${_ver/[a-z]/.${_ver//[0-9.]/}}
pkgrel=1
pkgdesc='The Open Source toolkit for Secure Sockets Layer and Transport Layer Security (with static libs)'
-arch=('x86_64')
+arch=('x86_64' 'aarch64' 'armv7h' 'i686' 'pentium4' 'riscv64')
url='https://www.openssl.org'
license=('Apache')
depends=('glibc')
@@ -21,7 +22,7 @@ options=('staticlibs')
conflicts=('openssl')
source=("https://www.openssl.org/source/${_pkgname}-${_ver}.tar.gz"{,.asc}
'ca-dir.patch')
-sha256sums=('a0ce69b8b97ea6a35b96875235aa453b966ba3cba8af2de23657d8b6767d6539'
+sha256sums=('53e66b043322a606abf0087e7699a0e033a37fa13feb9742df35c3a33b18fb02'
'SKIP'
'0a32d9ca68e8d985ce0bfef6a4c20b46675e06178cc2d0bf6d91bd6865d648b7')
validpgpkeys=('8657ABB260F056B1E5190839D9C4D26D0E604491'
@@ -43,7 +44,7 @@ build() {
export CFLAGS="-fPIC ${CFLAGS}"
# mark stack as non-executable: http://bugs.archlinux.org/task/12434
./Configure --prefix=/usr --openssldir=/etc/ssl --libdir=lib \
- shared enable-ktls enable-ec_nistp_64_gcc_128 linux-x86_64 \
+ shared enable-ktls enable-ec_nistp_64_gcc_128 linux-${CARCH} \
"-Wa,--noexecstack ${CPPFLAGS} ${CFLAGS} ${LDFLAGS}"
make depend