summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD27
3 files changed, 19 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e18a50ac94fe..936f4c80323b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = alpm_octopi_utils
pkgdesc = Alpm utils for Octopi
pkgver = 1.0.2
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/aarnt/alpm_octopi_utils
arch = x86_64
license = GPL-3.0-or-later
+ makedepends = cmake
makedepends = git
makedepends = vala
depends = pacman-contrib
provides = alpm-octopi-utils
source = git+https://github.com/aarnt/alpm_octopi_utils.git#commit=1e735c3a27803ca5b6470e946f9cac708143dfd9
- source = https://github.com/aarnt/alpm_octopi_utils/pull/4.patch
sha256sums = SKIP
- sha256sums = c117f3a86f6428f671723b921229fdfe3e61b057efae1e0b3b2b1a2993ef8842
pkgname = alpm_octopi_utils
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 3a20150f94d8..5d80f79f0096 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,26 @@
# Contributor: MatMoul <matmoul at the google email domain which is .com>
pkgname=alpm_octopi_utils
pkgver=1.0.2
-pkgrel=5
+pkgrel=6
pkgdesc="Alpm utils for Octopi"
arch=('x86_64')
url="https://github.com/aarnt/alpm_octopi_utils"
license=('GPL-3.0-or-later')
depends=('pacman-contrib')
-makedepends=('git' 'vala')
+makedepends=('cmake' 'git' 'vala')
provides=('alpm-octopi-utils')
_commit=1e735c3a27803ca5b6470e946f9cac708143dfd9 # master
-source=("git+https://github.com/aarnt/alpm_octopi_utils.git#commit=$_commit"
- 'https://github.com/aarnt/alpm_octopi_utils/pull/4.patch')
-sha256sums=('SKIP'
- 'c117f3a86f6428f671723b921229fdfe3e61b057efae1e0b3b2b1a2993ef8842')
-
-prepare() {
- cd alpm_octopi_utils
-
- # Add DESTDIR to Makefile
- patch -Np1 -i ../4.patch
-}
+source=("git+https://github.com/aarnt/alpm_octopi_utils.git#commit=$_commit")
+sha256sums=('SKIP')
build() {
- cd alpm_octopi_utils
- make
+ cmake -B build -S alpm_octopi_utils \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
+ cmake --build build
}
package() {
- cd alpm_octopi_utils
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}