summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
-rw-r--r--gnome-shell-extension-window-thumbnails.install8
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..727ac84b9bf3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gnome-shell-extension-window-thumbnails-git
+ pkgdesc = A GNOME Shell extension that allows the creation of scaled-down window clones for use as Picture-in-Picture (PIP) thumbnails (Github version).
+ pkgver = r38.a885f32
+ pkgrel = 1
+ url = https://github.com/G-dH/window-thumbnails
+ install = gnome-shell-extension-window-thumbnails.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gnome-shell
+ provides = gnome-shell-extension-window-thumbnails
+ conflicts = gnome-shell-extension-window-thumbnails
+ source = gnome-shell-extension-window-thumbnails::git+https://github.com/G-dH/window-thumbnails.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-window-thumbnails-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ffeddf43bc11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Mohammadreza Abdollahzadeh < morealaz at gmail dot com >
+pkgname=gnome-shell-extension-window-thumbnails-git
+pkgver=r38.a885f32
+pkgrel=1
+pkgdesc="A GNOME Shell extension that allows the creation of scaled-down window clones for use as Picture-in-Picture (PIP) thumbnails (Github version)."
+arch=('any')
+url="https://github.com/G-dH/window-thumbnails"
+license=('GPL3')
+conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}")
+depends=('gnome-shell')
+makedepends=('git')
+install="${pkgname%-git}.install"
+source=("${pkgname%-git}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${pkgname%-git}"
+ make zip
+}
+
+package() {
+ cd "${srcdir}/${pkgname%-git}"
+ install -d "${pkgdir}/usr/share/gnome-shell/extensions/window-thumbnails@G-dH.github.com"
+ bsdtar -xf "window-thumbnails@G-dH.github.com.zip" \
+ -C "${pkgdir}/usr/share/gnome-shell/extensions/window-thumbnails@G-dH.github.com"
+}
+# vim:set ts=4 sw=4 et:
diff --git a/gnome-shell-extension-window-thumbnails.install b/gnome-shell-extension-window-thumbnails.install
new file mode 100644
index 000000000000..b3af39da5d7d
--- /dev/null
+++ b/gnome-shell-extension-window-thumbnails.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo ''
+ echo '==> To enable WTMB (Window Thumbnails):'
+ echo '==> Reload Gnome Shell with Alt-F2 r (on Xorg), logout -> login (Wayland)'
+ echo '==> Enable it with the extensions tool'
+ echo '==> or run "gnome-extensions enable window-thumbnails@G-dH.github.com"'
+ echo ''
+}