summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiKl-LS2023-03-18 13:41:38 +0800
committerMiKl-LS2023-03-18 13:41:38 +0800
commit396151c414ccebbc2c2324a38898f93a95e3a3d4 (patch)
tree82280e15c4488f845579225e0895337b8439394f
parentbe1067402844da74da7d0abc4f037be52aad3b44 (diff)
downloadaur-rtl8821cu-morrownr-dkms-git.tar.gz
Fully use variable
-rwxr-xr-xPKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fc994d6d0545..1f520507a61e 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,18 +21,18 @@ sha256sums=('SKIP'
prepare() {
if [ $CARCH = "armv7h" ]; then
- sed -i 's/CONFIG_PLATFORM_I386_PC = y/CONFIG_PLATFORM_I386_PC = n/g' ${srcdir}/8821cu-20210118/Makefile
- sed -i 's/CONFIG_PLATFORM_ARM_RPI = n/CONFIG_PLATFORM_ARM_RPI = y/g' ${srcdir}/8821cu-20210118/Makefile
+ sed -i 's/CONFIG_PLATFORM_I386_PC = y/CONFIG_PLATFORM_I386_PC = n/g' ${srcdir}/8821cu-${repoversion}/Makefile
+ sed -i 's/CONFIG_PLATFORM_ARM_RPI = n/CONFIG_PLATFORM_ARM_RPI = y/g' ${srcdir}/8821cu-${repoversion}/Makefile
elif [ $CARCH = "aarch64" ]; then
- sed -i 's/CONFIG_PLATFORM_I386_PC = y/CONFIG_PLATFORM_I386_PC = n/g' ${srcdir}/8821cu-20210118/Makefile
- sed -i 's/CONFIG_PLATFORM_ARM_RPI = y/CONFIG_PLATFORM_ARM_RPI = n/g' ${srcdir}/8821cu-20210118/Makefile
- sed -i 's/CONFIG_PLATFORM_ARM64_RPI = n/CONFIG_PLATFORM_ARM64_RPI = y/g' ${srcdir}/8821cu-20210118/Makefile
+ sed -i 's/CONFIG_PLATFORM_I386_PC = y/CONFIG_PLATFORM_I386_PC = n/g' ${srcdir}/8821cu-${repoversion}/Makefile
+ sed -i 's/CONFIG_PLATFORM_ARM_RPI = y/CONFIG_PLATFORM_ARM_RPI = n/g' ${srcdir}/8821cu-${repoversion}/Makefile
+ sed -i 's/CONFIG_PLATFORM_ARM64_RPI = n/CONFIG_PLATFORM_ARM64_RPI = y/g' ${srcdir}/8821cu-${repoversion}/Makefile
fi
}
pkgver() {
- cd ${srcdir}/8821cu-20210916
+ cd ${srcdir}/8821cu-${repoversion}
printf "%s" ${_pkgver} "." "$(git rev-list --count HEAD)" "." "$(git rev-parse --short HEAD)"
}