summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12024-06-12 12:03:33 +0800
committerChocobo12024-06-12 12:08:05 +0800
commita7ea53050247e722d84308f7a37464cf012a8ab2 (patch)
treed931a34542109be59902ced694319503d83c3f11 /PKGBUILD
parent0fead4186f4c3836d045d6a4a3c02cb5d5eb2c72 (diff)
downloadaur-hicolor-icon-theme-git.tar.gz
upgpkg: hicolor-icon-theme-git 0.18.r2.gf83ba10-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 438763223676..6591fe13fdd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=hicolor-icon-theme-git
-pkgver=0.17.r1.gb3f1207
+pkgver=0.18.r2.gf83ba10
pkgrel=1
pkgdesc="Freedesktop.org Hicolor icon theme"
arch=('any')
url="https://www.freedesktop.org/wiki/Software/icon-theme/"
-license=('GPL')
-makedepends=('git')
+license=('GPL-2.0-or-later')
+makedepends=('git' 'meson')
provides=("hicolor-icon-theme=$pkgver")
conflicts=('hicolor-icon-theme')
source=("git+https://gitlab.freedesktop.org/xdg/default-icon-theme")
@@ -23,14 +23,21 @@ pkgver() {
build() {
cd "default-icon-theme"
- ./autogen.sh --no-configure
- ./configure \
- --prefix="/usr"
- make
+ meson setup \
+ --buildtype=plain \
+ --prefix="/usr" \
+ "_build"
+ meson compile -C "_build"
+}
+
+check() {
+ cd "default-icon-theme"
+
+ #meson test -C "_build"
}
package() {
cd "default-icon-theme"
- make DESTDIR="$pkgdir" install
+ meson install -C "_build" --destdir "$pkgdir"
}