summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2024-05-27 09:00:46 +0200
committerPiotr Gorski2024-05-27 09:00:46 +0200
commit65f27675b0cfd11649bbf8d6a97c8dd97855f293 (patch)
treec4c8fb3b67f83370739ab9ce1620b04bd3e47e00 /PKGBUILD
parent9eb5efc90e080cac1e814ea21df04e00839330d1 (diff)
downloadaur-linux-cachyos-lts.tar.gz
Bump to 6.6.32
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 5 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 42b4bccd1765..5795dad96699 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -170,7 +170,7 @@ elif [ -n "$_use_llvm_lto" ] || [[ "$_use_lto_suffix" = "n" ]]; then
pkgbase=linux-$pkgsuffix
fi
_major=6.6
-_minor=31
+_minor=32
#_minorc=$((_minor+1))
#_rcver=rc8
pkgver=${_major}.${_minor}
@@ -199,7 +199,7 @@ if [[ "$_use_llvm_lto" = "thin" || "$_use_llvm_lto" = "full" ]] || [ -n "$_use_k
fi
_patchsource="https://raw.githubusercontent.com/cachyos/kernel-patches/master/${_major}"
-_nv_ver=550.78
+_nv_ver=555.42.02
_nv_pkg="NVIDIA-Linux-x86_64-${_nv_ver}"
_nv_open_pkg="open-gpu-kernel-modules-${_nv_ver}"
source=(
@@ -222,14 +222,12 @@ fi
# NVIDIA pre-build module support
if [ -n "$_build_nvidia" ]; then
source+=("https://us.download.nvidia.com/XFree86/Linux-x86_64/${_nv_ver}/${_nv_pkg}.run"
- "${_patchsource}/misc/nvidia/make-modeset-fbdev-default.patch"
- "${_patchsource}/misc/nvidia/0001-NVIDIA-take-modeset-ownership-early.patch")
+ "${_patchsource}/misc/nvidia/make-modeset-fbdev-default.patch")
fi
if [ -n "$_build_nvidia_open" ]; then
source+=("nvidia-open-${_nv_ver}.tar.gz::https://github.com/NVIDIA/open-gpu-kernel-modules/archive/refs/tags/${_nv_ver}.tar.gz"
"${_patchsource}/misc/nvidia/make-modeset-fbdev-default.patch"
- "${_patchsource}/misc/nvidia/0001-NVIDIA-take-modeset-ownership-early.patch"
"${_patchsource}/misc/nvidia/nvidia-open-gcc-ibt-sls.patch")
fi
@@ -280,7 +278,6 @@ prepare() {
src="${src##*/}"
src="${src%.zst}"
[[ $src = make-modeset-fbdev-default.patch ]] && continue
- [[ $src = 0001-NVIDIA-take-modeset-ownership-early.patch ]] && continue
[[ $src = nvidia-open-gcc-ibt-sls.patch ]] && continue
[[ $src = *.patch ]] || continue
echo "Applying patch $src..."
@@ -576,13 +573,10 @@ prepare() {
# Use fbdev and modeset as default
patch -Np1 -i "${srcdir}/make-modeset-fbdev-default.patch" -d "${srcdir}/${_nv_pkg}/kernel"
- patch -Np2 --no-backup-if-mismatch -i "${srcdir}/0001-NVIDIA-take-modeset-ownership-early.patch" -d "${srcdir}/${_nv_pkg}/kernel"
fi
if [ -n "$_build_nvidia_open" ]; then
patch -Np1 -i "${srcdir}/make-modeset-fbdev-default.patch" -d "${srcdir}/${_nv_open_pkg}/kernel-open"
- patch -Np2 --no-backup-if-mismatch -i "${srcdir}/0001-NVIDIA-take-modeset-ownership-early.patch" -d "${srcdir}/${_nv_open_pkg}/kernel-open"
-
# Fix for https://bugs.archlinux.org/task/74886
patch -Np1 --no-backup-if-mismatch -i "${srcdir}/nvidia-open-gcc-ibt-sls.patch" -d "${srcdir}/${_nv_open_pkg}"
fi
@@ -800,8 +794,8 @@ for _p in "${pkgname[@]}"; do
}"
done
-sha256sums=('d6ecff966f8c95ec4cb3bb303904f757b7de6a6bcfef0d0771cb852158e61c20'
- 'fdc2b032badafe9eb4b5e27925df057fe6d24dc0803bd37dd4be895f3606dbed'
+sha256sums=('aaa824eaf07f61911d22b75ff090a403c3dd0bd73e23933e0bba8b5971436ce1'
+ '821efb2826857d9ab0073366c1f717bd631d146282dab07fd6cbb9f91e088643'
'3f3233256725683aa95c29ee423932a5bcc74c0653e09d502240601387c3edec'
'794a5b743bd94a715957dc5fa391c3e3cd283b4aa12a4af9487565639192ef72'
'e5bac2247f709a073ff5c901e9ec2043641d0cf61d8e64dcdfd35f489c72c13a')