summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeorge Rawlinson2022-05-05 19:34:36 +1200
committerGeorge Rawlinson2022-05-05 19:34:36 +1200
commit01105c17e4d34e9bc047ac2d22753ae0b2707da2 (patch)
treead65b6e50346e8c0b4d8f24c1c1f4c16fab67744 /PKGBUILD
parent7a389c47ef5dd87f45e8675de59957b494c40bf4 (diff)
downloadaur-npt.tar.gz
upgpkg: npt 1.1.1-2
* Add dependency: readline. * Add documentation.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 19 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e2848ee4b10..42054cb2bce1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=npt
pkgver=1.1.1
-pkgrel=1
-pkgdesc='ANSI Common Lisp implementation'
+pkgrel=2
+pkgdesc='ANSI Common Lisp Implementation'
arch=('x86_64')
url='https://github.com/nptcl/npt'
license=('Unlicense')
-depends=('glibc')
+depends=('glibc' 'readline')
makedepends=('git')
_commit='55cff1db7e6f12f7e87e8ab26393792d33734d62'
source=("$pkgname::git+$url#commit=$_commit")
@@ -19,12 +19,23 @@ pkgver() {
git describe --tags | sed 's/^v//'
}
+prepare() {
+ cd "$pkgname"
+
+ # fix typo
+ sed \
+ -i Makefile.am \
+ -e 's/incldue/include/g'
+}
+
build() {
cd "$pkgname"
./bootstrap.sh
- ./configure --prefix=/usr
+ ./configure \
+ --prefix=/usr \
+ --with-readline
make
}
@@ -32,5 +43,9 @@ build() {
package() {
cd "$pkgname"
+ # binary
make install DESTDIR="$pkgdir"
+
+ # documentation
+ install -vDm644 -t "$pkgdir/usr/share/doc/$pkgname" docs/*.html
}