summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f5b613c1241..badc29210225 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = opentyrian2000
pkgdesc = Open Source port of the classic DOS shoot-em-up Tyrian2000
pkgver = 2000.20200917
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/KScl/opentyrian2000
arch = x86_64
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index 9e2b37866500..d06785ca15cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=opentyrian2000
pkgver=2000.20200917
-pkgrel=1
+pkgrel=2
pkgdesc='Open Source port of the classic DOS shoot-em-up Tyrian2000'
url="https://github.com/KScl/opentyrian2000"
arch=('x86_64')
@@ -41,13 +41,21 @@ prepare() {
}
build() {
- make prefix=/usr all -C "$pkgname"
+ make \
+ -C "$pkgname" \
+ prefix=/usr \
+ gamesdir=/usr/share \
+ all
}
package() {
cd "$pkgname"
- make DESTDIR="$pkgdir" prefix=/usr install
+ make \
+ DESTDIR="$pkgdir" \
+ prefix=/usr \
+ gamesdir=/usr/share \
+ install
# desktop file & icons
install -vDm644 linux/opentyrian.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"