summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8dedced48d8..d6712795403b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = oscam-git
pkgdesc = Open Source Conditional Access Module software
- pkgver = 11719
+ pkgver = 11767
pkgrel = 1
url = http://www.streamboard.tv/oscam
install = oscam.install
@@ -11,14 +11,15 @@ pkgbase = oscam-git
arch = armv7h
arch = aarch64
license = GPL3
- makedepends = subversion
+ makedepends = git
depends = libusb
depends = openssl
depends = pcsclite
+ depends = libdvbcsa
optdepends = pcsclite: for use with PC/SC readers
optdepends = ccid: PC/SC reader generic driver
conflicts = oscam-svn
- source = oscam-git::svn+https://svn.streamboard.tv/oscam/trunk
+ source = oscam-git::git+https://git.streamboard.tv/common/oscam.git
source = oscam.service
source = oscam.sysuser
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index bc995d94c8e2..6c58f166a267 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,19 @@
# Author: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
# Maintainer: Julian Xhokaxhiu <info@julianxhokaxhiu.com>
pkgname=oscam-git
-pkgver=11719
+pkgver=11767
pkgrel=1
pkgdesc="Open Source Conditional Access Module software"
url="http://www.streamboard.tv/oscam"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
license=('GPL3')
-depends=('libusb' 'openssl' 'pcsclite')
-makedepends=('subversion')
+depends=('libusb' 'openssl' 'pcsclite' 'libdvbcsa')
+makedepends=('git')
optdepends=('pcsclite: for use with PC/SC readers'
'ccid: PC/SC reader generic driver')
conflicts=('oscam-svn')
install='oscam.install'
-source=("$pkgname::svn+https://svn.streamboard.tv/oscam/trunk"
+source=("$pkgname::git+https://git.streamboard.tv/common/oscam.git"
'oscam.service'
'oscam.sysuser')
sha256sums=('SKIP'
@@ -25,7 +25,7 @@ sha256sums=('SKIP'
pkgver() {
cd "$pkgname"
- LANG=C svn info | grep '^Revision:' | sed -e 's/^Revision: //'
+ ./config.sh --oscam-revision
}
build() {
@@ -40,7 +40,6 @@ build() {
USE_PCSC=1 \
OSCAM_BIN=oscam \
LIST_SMARGO_BIN=list_smargo \
- SVN_REV=$pkgver \
EXTRA_CC_WARN=-w
}