summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFreed-Wu2022-03-02 18:05:27 +0800
committerFreed-Wu2022-03-02 18:05:27 +0800
commit1962aef50651df7e197bbec0a8472ae82c68b5eb (patch)
tree4e969b055c5b42392125eed07ef1ebe0867695f2 /PKGBUILD
downloadaur-spark-bash.tar.gz
Initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6ae9b726a83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: wzy <wuzy01@qq.com>
+# https://aur.archlinux.org/packages/updaurpkg-git
+# $ updaurpkg .
+_repo='holman/spark'
+_source_type='github-tags'
+_upstreamver='v1.0.1'
+_pkgname=${_repo##*/}
+
+pkgname=$_pkgname-bash
+pkgver=${_upstreamver##v}
+pkgrel=1
+pkgdesc='▁▂▃▅▂▇ in your shell.'
+arch=('any')
+url="https://github.com/$_repo"
+license=('MIT')
+provides=("$_pkgname-$pkgver")
+conflicts=("$_pkgname-$pkgver")
+source=("$_pkgname-$pkgver::$url/archive/$_upstreamver.tar.gz")
+sha256sums=('a81c1bc538ce8e011f62264fe6f33d28042ff431b510a6359040dc77403ebab6')
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ install -D "$_pkgname" -t "$pkgdir/usr/bin"
+}