summarylogtreecommitdiffstats
path: root/.pre-commit-config.yaml
diff options
context:
space:
mode:
authorHongqi Yu2022-10-23 11:04:55 +0800
committerHongqi Yu2022-10-23 11:04:55 +0800
commit929c3321656388837b4f0e54aecb85d3d807d9ef (patch)
treede6d7c9d30f9ec84abb959b8b4ea720821ef7adc /.pre-commit-config.yaml
downloadaur-ticli-bin.tar.gz
initial commit
Diffstat (limited to '.pre-commit-config.yaml')
-rw-r--r--.pre-commit-config.yaml18
1 files changed, 18 insertions, 0 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
new file mode 100644
index 000000000000..369fe9b4d531
--- /dev/null
+++ b/.pre-commit-config.yaml
@@ -0,0 +1,18 @@
+# See https://pre-commit.com for more information
+# See https://pre-commit.com/hooks.html for more hooks
+repos:
+- repo: https://github.com/pre-commit/pre-commit-hooks
+ rev: v4.0.1
+ hooks:
+ - id: trailing-whitespace
+ - id: check-added-large-files
+ - id: mixed-line-ending
+- repo: local
+ hooks:
+ - id: makepkg
+ name: makepkg
+ pass_filenames: false
+ always_run: true
+ language: system
+ entry: |
+ sh -c 'make package && git add PKGBUILD .SRCINFO'