summarylogtreecommitdiffstats
path: root/0001-Fix-build-with-ICU-76.patch
diff options
context:
space:
mode:
authorselfdenial2025-02-23 23:39:41 -0700
committerselfdenial2025-02-23 23:39:41 -0700
commit946d76297bc2ae079e397b57d115d0bf96a24e33 (patch)
tree1afc1c9e593f5a4ea0a9d9f91c9f722c5d692411 /0001-Fix-build-with-ICU-76.patch
parentc114577d39601dd9d2cd62e141f821c600bf0a7b (diff)
downloadaur-libkiwix-git.tar.gz
build: Add ICU 76 build fix and update package version
Diffstat (limited to '0001-Fix-build-with-ICU-76.patch')
-rw-r--r--0001-Fix-build-with-ICU-76.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/0001-Fix-build-with-ICU-76.patch b/0001-Fix-build-with-ICU-76.patch
new file mode 100644
index 000000000000..25986560606a
--- /dev/null
+++ b/0001-Fix-build-with-ICU-76.patch
@@ -0,0 +1,37 @@
+From 0c39857fc325e50a77cb89feb215e62ae0aa8518 Mon Sep 17 00:00:00 2001
+From: hashworks <mail@hashworks.net>
+Date: Tue, 11 Feb 2025 18:07:18 +0100
+Subject: [PATCH] Fix build with ICU 76
+
+Due to unicode-org/icu@199bc82, ICU 76 no longer adds `icu-uc` by
+default. This causes linker errors for undefined symbols like
+`icu_76::UnicodeString::doReplace(...)`, referenced from:
+`zim::removeAccents(...)` in tools.cpp.o.
+
+Meson will automatically flatten the dependencies list as documented
+at https://mesonbuild.com/Reference-manual_functions.html#build_target
+
+Original commit from https://github.com/openzim/libzim/pull/936
+---
+ meson.build | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 51052335..cff81217 100644
+--- a/meson.build
++++ b/meson.build
+@@ -48,7 +48,10 @@ if (host_machine.system() == 'linux' and compiler.get_id() == 'gcc') or \
+ else
+ thread_dep = dependency('', required:false)
+ endif
+-libicu_dep = dependency('icu-i18n', static:static_deps)
++libicu_dep = [
++ dependency('icu-i18n', static:static_deps),
++ dependency('icu-uc', static:static_deps)
++]
+ pugixml_dep = dependency('pugixml', static:static_deps)
+ libcurl_dep = dependency('libcurl', static:static_deps)
+ microhttpd_dep = dependency('libmicrohttpd', static:static_deps)
+--
+2.48.1
+