summarylogtreecommitdiffstats
path: root/0001-add-blur-effect-when-set-transparency.patch
diff options
context:
space:
mode:
authorleaeasy2018-04-23 10:57:39 +0800
committerleaeasy2018-04-23 11:00:08 +0800
commitbfcaa16c8f8c923f0a36836eaf01f244726e09bc (patch)
tree60bf7da45febecbe8c691d2a4310fcfb53149f25 /0001-add-blur-effect-when-set-transparency.patch
parente37fabe7d3b2d1de8ab6ed371c2fc3cac68d0bc3 (diff)
downloadaur-konsole-blurry.tar.gz
update 18.04.0
Diffstat (limited to '0001-add-blur-effect-when-set-transparency.patch')
-rw-r--r--0001-add-blur-effect-when-set-transparency.patch47
1 files changed, 19 insertions, 28 deletions
diff --git a/0001-add-blur-effect-when-set-transparency.patch b/0001-add-blur-effect-when-set-transparency.patch
index 66d19c11fb37..82067d18ab2b 100644
--- a/0001-add-blur-effect-when-set-transparency.patch
+++ b/0001-add-blur-effect-when-set-transparency.patch
@@ -1,40 +1,31 @@
-From 20e6d6223e3c14bf173edbf4633859146cb60a97 Mon Sep 17 00:00:00 2001
+From ffd6778743a5dd992f8dd195aa3d51b9c4a2ba80 Mon Sep 17 00:00:00 2001
From: leaeasy <leaeasy@gmail.com>
-Date: Sun, 23 Oct 2016 20:17:42 +0800
-Subject: [PATCH] add-blur-effect-when-set-transparency
+Date: Mon, 23 Apr 2018 10:37:14 +0800
+Subject: [PATCH 1/3] add blur effect when set transparency
---
- CMakeLists.txt | 3 ++-
+ CMakeLists.txt | 1 +
src/CMakeLists.txt | 2 ++
src/MainWindow.cpp | 11 +++++++++++
- 3 files changed, 15 insertions(+), 1 deletion(-)
+ 3 files changed, 14 insertions(+)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 18b6e49..51f7c0e 100644
+index ef79ae2..493a924 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -35,6 +35,7 @@ find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED
+@@ -38,6 +38,7 @@ find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED
+ DBus
PrintSupport
- Script
Widgets
+ X11Extras
)
find_package(KF5 ${KF5_MIN_VERSION} REQUIRED
-@@ -42,7 +43,7 @@ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED
- CoreAddons Crash GuiAddons DBusAddons
- I18n IconThemes Init KIO Notifications NotifyConfig
- Parts Pty Service TextWidgets WidgetsAddons
-- WindowSystem XmlGui DBusAddons
-+ WindowSystem XmlGui DBusAddons
- )
-
- find_package(KF5DocTools ${KF5_MIN_VERSION})
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 25f6e57..6077ed0 100644
+index fa15a52..1d8ab0c 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
-@@ -108,6 +108,7 @@ set(konsole_LIBS
+@@ -113,6 +113,7 @@ set(konsole_LIBS
KF5::XmlGui
Qt5::PrintSupport
Qt5::Xml
@@ -42,19 +33,19 @@ index 25f6e57..6077ed0 100644
KF5::Notifications
KF5::WindowSystem
KF5::TextWidgets
-@@ -118,6 +119,7 @@ set(konsole_LIBS
- KF5::Pty
- KF5::KIOWidgets
+@@ -125,6 +126,7 @@ set(konsole_LIBS
KF5::DBusAddons
-+ ${X11_LIBRARIES}
+ KF5::GlobalAccel
+ KF5::NewStuff
++ ${X11_LIBRARIES}
)
if(${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
diff --git a/src/MainWindow.cpp b/src/MainWindow.cpp
-index 803eeaf..dfca483 100644
+index e78858d..928eedd 100644
--- a/src/MainWindow.cpp
+++ b/src/MainWindow.cpp
-@@ -56,6 +56,12 @@
+@@ -59,6 +59,12 @@
#include "settings/ProfileSettings.h"
#include "settings/TabBarSettings.h"
@@ -66,8 +57,8 @@ index 803eeaf..dfca483 100644
+
using namespace Konsole;
- MainWindow::MainWindow()
-@@ -135,6 +141,11 @@ void MainWindow::updateUseTransparency()
+ MainWindow::MainWindow() :
+@@ -151,6 +157,11 @@ void MainWindow::updateUseTransparency()
setAttribute(Qt::WA_TranslucentBackground, useTranslucency);
setAttribute(Qt::WA_NoSystemBackground, false);
WindowSystemInfo::HAVE_TRANSPARENCY = useTranslucency;
@@ -80,5 +71,5 @@ index 803eeaf..dfca483 100644
void MainWindow::rememberMenuAccelerators()
--
-2.10.1
+2.17.0