summarylogtreecommitdiffstats
path: root/0001-fix-glslang-hlsl-linking-order.patch
diff options
context:
space:
mode:
authoratomlong2021-09-11 20:45:11 +0800
committeratomlong2021-09-11 22:20:03 +0800
commitf21a1fbc62af15b658477110dc65a83f35dc3390 (patch)
treec5468844d3a1bd34e1ed4998a00e7344b2999936 /0001-fix-glslang-hlsl-linking-order.patch
parentc4dbd8db547c30d8462cddf383f52373a51b59c7 (diff)
downloadaur-mingw-w64-shaderc.tar.gz
update to 2021.2
Diffstat (limited to '0001-fix-glslang-hlsl-linking-order.patch')
-rw-r--r--0001-fix-glslang-hlsl-linking-order.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/0001-fix-glslang-hlsl-linking-order.patch b/0001-fix-glslang-hlsl-linking-order.patch
new file mode 100644
index 000000000000..1c16e188232d
--- /dev/null
+++ b/0001-fix-glslang-hlsl-linking-order.patch
@@ -0,0 +1,13 @@
+--- a/libshaderc_util/CMakeLists.txt
++++ b/libshaderc_util/CMakeLists.txt
+@@ -46,8 +46,8 @@
+
+ find_package(Threads)
+ target_link_libraries(shaderc_util PRIVATE
+- glslang OSDependent OGLCompiler HLSL glslang SPIRV
+- SPIRV-Tools-opt ${CMAKE_THREAD_LIBS_INIT})
++ MachineIndependent GenericCodeGen glslang OSDependent OGLCompiler glslang HLSL SPIRV
++ SPIRV-Tools-opt SPIRV-Tools ${CMAKE_THREAD_LIBS_INIT})
+
+ shaderc_add_tests(
+ TEST_PREFIX shaderc_util