summarylogtreecommitdiffstats
path: root/0001-fix_include.patch
diff options
context:
space:
mode:
authorNarrat2024-02-23 22:48:33 +0100
committerNarrat2024-02-23 22:49:48 +0100
commit4e49db01d1974bc65a989d82da52b40c5ef9ff94 (patch)
tree4ab3071cf7e9c6cb992115acc56ef4fab1f306f5 /0001-fix_include.patch
parentfddae42777a7fd7724eedba9fe9de39d99dbb171 (diff)
downloadaur-monkey.tar.gz
monkey: fix build
add patch which adjusts the include dir. And add the configure step again in package(). If that is omitted it will install the files into /usr/local
Diffstat (limited to '0001-fix_include.patch')
-rw-r--r--0001-fix_include.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/0001-fix_include.patch b/0001-fix_include.patch
new file mode 100644
index 000000000000..a5d657a33684
--- /dev/null
+++ b/0001-fix_include.patch
@@ -0,0 +1,16 @@
+--- a/monkey-1.7.3/include/CMakeLists.txt
++++ b/monkey-1.7.3/include/CMakeLists.txt
+@@ -1,10 +1,10 @@
+ # MK_CORE
+ if(NOT WITHOUT_HEADERS)
+- install(FILES "mk_core.h"
++ install(FILES "monkey/mk_core.h"
+ DESTINATION include/
+ PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ)
+
+- file(GLOB headers "mk_core/*.h")
++ file(GLOB headers "monkey/mk_core/*.h")
+ install(FILES ${headers}
+ DESTINATION include/mk_core
+ PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ)
+