summarylogtreecommitdiffstats
path: root/0002-Disable-neon.patch
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2024-03-26 16:53:02 -0300
committerGonzalo Exequiel Pedone2024-03-26 16:53:02 -0300
commitea6db587db1bd365e02e2dd4d21fd94c16e20179 (patch)
tree825eb4f864ff4bdc03962522c7ee33caa5f75914 /0002-Disable-neon.patch
downloadaur-android-x86-64-snappy.tar.gz
New package.
Diffstat (limited to '0002-Disable-neon.patch')
-rw-r--r--0002-Disable-neon.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/0002-Disable-neon.patch b/0002-Disable-neon.patch
new file mode 100644
index 000000000000..04ba74e23805
--- /dev/null
+++ b/0002-Disable-neon.patch
@@ -0,0 +1,18 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -191,15 +191,6 @@
+ return _bzhi_u32(0, 1);
+ }" SNAPPY_HAVE_BMI2)
+
+-check_cxx_source_compiles("
+-#include <arm_neon.h>
+-int main() {
+- uint8_t val = 3, dup[8];
+- uint8x16_t v = vld1q_dup_u8(&val);
+- vst1q_u8(dup, v);
+- return 0;
+-}" SNAPPY_HAVE_NEON)
+-
+ include(CheckSymbolExists)
+ check_symbol_exists("mmap" "sys/mman.h" HAVE_FUNC_MMAP)
+ check_symbol_exists("sysconf" "unistd.h" HAVE_FUNC_SYSCONF)