summarylogtreecommitdiffstats
path: root/0002-Makefile-disallow-data-races-on-gcc-10-as-well.patch
diff options
context:
space:
mode:
authorDavid Runge2020-05-14 12:38:49 +0200
committerDavid Runge2020-05-14 12:38:49 +0200
commit15456fc6c06c0d18cd13c9bb36e94841453d97eb (patch)
treefd1d4c51c3cabd704660b65fd462697521e3459b /0002-Makefile-disallow-data-races-on-gcc-10-as-well.patch
parentb4505d0115795adf5f5e87f6832dab32e1834a49 (diff)
downloadaur-15456fc6c06c0d18cd13c9bb36e94841453d97eb.tar.gz
Upgrading to 5.4.39.23.
Adding upstream patches for gcc >= 10.1.0.
Diffstat (limited to '0002-Makefile-disallow-data-races-on-gcc-10-as-well.patch')
-rw-r--r--0002-Makefile-disallow-data-races-on-gcc-10-as-well.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/0002-Makefile-disallow-data-races-on-gcc-10-as-well.patch b/0002-Makefile-disallow-data-races-on-gcc-10-as-well.patch
new file mode 100644
index 000000000000..b6676eed647e
--- /dev/null
+++ b/0002-Makefile-disallow-data-races-on-gcc-10-as-well.patch
@@ -0,0 +1,32 @@
+From 6a183a41a1945cb79660a78536182ce9c2568291 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Tue, 17 Mar 2020 00:07:18 +0000
+Subject: [PATCH 2/3] Makefile: disallow data races on gcc-10 as well
+
+gcc-10 will rename --param=allow-store-data-races=0
+to -fno-allow-store-data-races.
+
+The flag change happened at https://gcc.gnu.org/PR92046.
+
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+Acked-by: Jiri Kosina <jkosina@suse.cz>
+Signed-off-by: Masahiro Yamada <masahiroy@kernel.org>
+---
+ Makefile | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile b/Makefile
+index ff2b90ddc9bc..c8dc1357079b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -713,6 +713,7 @@ endif
+
+ # Tell gcc to never replace conditional load with a non-conditional one
+ KBUILD_CFLAGS += $(call cc-option,--param=allow-store-data-races=0)
++KBUILD_CFLAGS += $(call cc-option,-fno-allow-store-data-races)
+
+ include scripts/Makefile.kcov
+ include scripts/Makefile.gcc-plugins
+--
+2.26.2
+