summarylogtreecommitdiffstats
path: root/0014-drm-amdgpu-Add-DC-feature-mask-to-disable-fractional.patch
diff options
context:
space:
mode:
authorDavid Runge2020-04-07 00:29:03 +0200
committerDavid Runge2020-04-07 00:29:03 +0200
commit014e95c2d5d897a3925709ea90ad48bcdc652b60 (patch)
tree4296368deb157f4fa0d11095e2e81ad55c36ec2c /0014-drm-amdgpu-Add-DC-feature-mask-to-disable-fractional.patch
parent3836213ce8b777268b786b2b6b01359994562696 (diff)
downloadaur-014e95c2d5d897a3925709ea90ad48bcdc652b60.tar.gz
PKGBUILD: Upgrading to 5.6.2.1.
Updating config to 5.6. Removing all but the standard patches (they're upstreamed or irrelevant now). Simplifying the PKGBUILD based on current core/linux.
Diffstat (limited to '0014-drm-amdgpu-Add-DC-feature-mask-to-disable-fractional.patch')
-rw-r--r--0014-drm-amdgpu-Add-DC-feature-mask-to-disable-fractional.patch80
1 files changed, 0 insertions, 80 deletions
diff --git a/0014-drm-amdgpu-Add-DC-feature-mask-to-disable-fractional.patch b/0014-drm-amdgpu-Add-DC-feature-mask-to-disable-fractional.patch
deleted file mode 100644
index 441f1208aa2f..000000000000
--- a/0014-drm-amdgpu-Add-DC-feature-mask-to-disable-fractional.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-From a952be50df891611e459512fc05818238c2c4cd0 Mon Sep 17 00:00:00 2001
-From: Leo Li <sunpeng.li@amd.com>
-Date: Mon, 21 Oct 2019 14:58:47 -0400
-Subject: [PATCH 14/15] drm/amdgpu: Add DC feature mask to disable fractional
- pwm
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-[Why]
-
-Some LED panel drivers might not like fractional PWM. In such cases,
-backlight flickering may be observed.
-
-[How]
-
-Add a DC feature mask to disable fractional PWM, and associate it with
-the preexisting dc_config flag.
-
-The flag is only plumbed through the dmcu firmware, so plumb it through
-the driver path as well.
-
-To disable, add the following to the linux cmdline:
-amdgpu.dcfeaturemask=0x4
-
-Bugzilla: https://bugzilla.kernel.org/show_bug.cgi?id=204957
-Signed-off-by: Leo Li <sunpeng.li@amd.com>
-Reviewed-by: Anthony Koo <anthony.koo@amd.com>
-Tested-by: Lukáš Krejčí <lskrejci@gmail.com>
-Signed-off-by: Alex Deucher <alexander.deucher@amd.com>
----
- drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c | 3 +++
- drivers/gpu/drm/amd/display/dc/dce/dce_abm.c | 4 ++++
- drivers/gpu/drm/amd/include/amd_shared.h | 1 +
- 3 files changed, 8 insertions(+)
-
-diff --git a/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c b/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
-index 4e9c15c409ba..25b72eb76add 100644
---- a/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
-+++ b/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
-@@ -697,6 +697,9 @@ static int amdgpu_dm_init(struct amdgpu_device *adev)
- if (amdgpu_dc_feature_mask & DC_MULTI_MON_PP_MCLK_SWITCH_MASK)
- init_data.flags.multi_mon_pp_mclk_switch = true;
-
-+ if (amdgpu_dc_feature_mask & DC_DISABLE_FRACTIONAL_PWM_MASK)
-+ init_data.flags.disable_fractional_pwm = true;
-+
- init_data.flags.power_down_display_on_boot = true;
-
- #ifdef CONFIG_DRM_AMD_DC_DCN2_0
-diff --git a/drivers/gpu/drm/amd/display/dc/dce/dce_abm.c b/drivers/gpu/drm/amd/display/dc/dce/dce_abm.c
-index 7700a855d77c..698b84acc44f 100644
---- a/drivers/gpu/drm/amd/display/dc/dce/dce_abm.c
-+++ b/drivers/gpu/drm/amd/display/dc/dce/dce_abm.c
-@@ -404,6 +404,10 @@ static bool dce_abm_init_backlight(struct abm *abm)
- /* Enable the backlight output */
- REG_UPDATE(BL_PWM_CNTL, BL_PWM_EN, 1);
-
-+ /* Disable fractional pwm if configured */
-+ REG_UPDATE(BL_PWM_CNTL, BL_PWM_FRACTIONAL_EN,
-+ abm->ctx->dc->config.disable_fractional_pwm ? 0 : 1);
-+
- /* Unlock group 2 backlight registers */
- REG_UPDATE(BL_PWM_GRP1_REG_LOCK,
- BL_PWM_GRP1_REG_LOCK, 0);
-diff --git a/drivers/gpu/drm/amd/include/amd_shared.h b/drivers/gpu/drm/amd/include/amd_shared.h
-index 8889aaceec60..5450ed762b7a 100644
---- a/drivers/gpu/drm/amd/include/amd_shared.h
-+++ b/drivers/gpu/drm/amd/include/amd_shared.h
-@@ -143,6 +143,7 @@ enum PP_FEATURE_MASK {
- enum DC_FEATURE_MASK {
- DC_FBC_MASK = 0x1,
- DC_MULTI_MON_PP_MCLK_SWITCH_MASK = 0x2,
-+ DC_DISABLE_FRACTIONAL_PWM_MASK = 0x4,
- };
-
- enum amd_dpm_forced_level;
---
-2.25.0
-