summarylogtreecommitdiffstats
path: root/0106-build-Disable-checks-for-dlopen-dlfcn.patch
diff options
context:
space:
mode:
authoratomlong2021-10-23 17:55:22 +0800
committeratomlong2021-10-23 18:06:15 +0800
commit80096c8de4b34ec1ed8f30bb428918cd592b2424 (patch)
treeb48dd1e73de9ea35a4709fb6b93deb16331ec514 /0106-build-Disable-checks-for-dlopen-dlfcn.patch
parent89a67c05174951d172252b1db96ff93cc4ec4bcd (diff)
downloadaur-mingw-w64-python.tar.gz
update to 3.9.7
Diffstat (limited to '0106-build-Disable-checks-for-dlopen-dlfcn.patch')
-rw-r--r--0106-build-Disable-checks-for-dlopen-dlfcn.patch66
1 files changed, 66 insertions, 0 deletions
diff --git a/0106-build-Disable-checks-for-dlopen-dlfcn.patch b/0106-build-Disable-checks-for-dlopen-dlfcn.patch
new file mode 100644
index 000000000000..605441a8ae48
--- /dev/null
+++ b/0106-build-Disable-checks-for-dlopen-dlfcn.patch
@@ -0,0 +1,66 @@
+From 33575171384e6e85efaf11ed9210463a870a7258 Mon Sep 17 00:00:00 2001
+From: Christoph Reiter <reiter.christoph@gmail.com>
+Date: Sun, 25 Jul 2021 13:54:12 +0200
+Subject: [PATCH 106/N] build: Disable checks for dlopen/dlfcn
+
+While it is (potentially) available with mingw we don't want to use it, so skip any
+checks for it.
+---
+ configure.ac | 20 +++++++++++++++++---
+ 1 file changed, 17 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 6b21b79..12373f7 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -2423,7 +2423,7 @@ dnl AC_MSG_RESULT($cpp_type)
+
+ # checks for header files
+ AC_HEADER_STDC
+-AC_CHECK_HEADERS(asm/types.h crypt.h conio.h direct.h dlfcn.h errno.h \
++AC_CHECK_HEADERS(asm/types.h crypt.h conio.h direct.h errno.h \
+ fcntl.h grp.h \
+ ieeefp.h io.h langinfo.h libintl.h process.h \
+ shadow.h signal.h stropts.h termios.h \
+@@ -2437,6 +2437,12 @@ sys/times.h sys/types.h sys/uio.h sys/un.h sys/utsname.h sys/wait.h pty.h \
+ libutil.h sys/resource.h netpacket/packet.h sysexits.h bluetooth.h \
+ linux/tipc.h linux/random.h spawn.h util.h alloca.h endian.h \
+ sys/endian.h sys/sysmacros.h linux/memfd.h linux/wait.h sys/memfd.h sys/mman.h)
++
++case $host in
++ *-*-mingw*) ;;
++ *) AC_CHECK_HEADERS([dlfcn.h]);;
++esac
++
+ AC_HEADER_DIRENT
+ AC_HEADER_MAJOR
+
+@@ -3108,7 +3114,12 @@ AC_MSG_RESULT($SHLIBS)
+
+ # checks for libraries
+ AC_CHECK_LIB(sendfile, sendfile)
+-AC_CHECK_LIB(dl, dlopen) # Dynamic linking for SunOS/Solaris and SYSV
++
++case $host in
++ *-*-mingw*) ;;
++ *) AC_CHECK_LIB(dl, dlopen) ;; # Dynamic linking for SunOS/Solaris and SYSV
++esac
++
+ AC_CHECK_LIB(dld, shl_load) # Dynamic linking for HP-UX
+
+ # checks for uuid.h location
+@@ -5014,7 +5025,10 @@ then
+ [define to 1 if your sem_getvalue is broken.])
+ fi
+
+-AC_CHECK_DECLS([RTLD_LAZY, RTLD_NOW, RTLD_GLOBAL, RTLD_LOCAL, RTLD_NODELETE, RTLD_NOLOAD, RTLD_DEEPBIND, RTLD_MEMBER], [], [], [[#include <dlfcn.h>]])
++case $host in
++ *-*-mingw*) ;;
++ *) AC_CHECK_DECLS([RTLD_LAZY, RTLD_NOW, RTLD_GLOBAL, RTLD_LOCAL, RTLD_NODELETE, RTLD_NOLOAD, RTLD_DEEPBIND, RTLD_MEMBER], [], [], [[#include <dlfcn.h>]]);;
++esac
+
+ # determine what size digit to use for Python's longs
+ AC_MSG_CHECKING([digit size for Python's longs])
+--
+2.33.0
+