summarylogtreecommitdiffstats
path: root/020-fix-no-copy-dt-needed.patch
diff options
context:
space:
mode:
authorMarcell Meszaros2023-12-26 19:51:19 +0100
committerMarcell Meszaros2023-12-26 21:40:52 +0100
commit7cdc6d54f00fa2298474c733746078128e9383b1 (patch)
tree0c86241e5801f81cf4daf80adca780d94a32a510 /020-fix-no-copy-dt-needed.patch
parent179519f5afe13867c87cc1b2cd0dbe130effa805 (diff)
downloadaur-monkey-bubble.tar.gz
0.4.0.r989.g3f15c50-1: update to latest github/sudheesh001/monkey-bubble commit version
Diffstat (limited to '020-fix-no-copy-dt-needed.patch')
-rw-r--r--020-fix-no-copy-dt-needed.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/020-fix-no-copy-dt-needed.patch b/020-fix-no-copy-dt-needed.patch
new file mode 100644
index 000000000000..1659b4a158a9
--- /dev/null
+++ b/020-fix-no-copy-dt-needed.patch
@@ -0,0 +1,22 @@
+Description: fix build with ld --as-needed
+ the libraries where placed before object files on the compile commandline
+ this leads to the references not being registered as needed and dropped.
+Bug-Ubuntu: https://bugs.launchpad.net/ubuntu/+source/monkey-bubble/+bug/771130
+Author: Julian Taylor <jtaylor.debian@googlemail.com>
+Index: monkey-bubble/src/net/Makefile.am
+===================================================================
+--- monkey-bubble.orig/src/net/Makefile.am 2011-07-02 19:06:24.189604281 +0200
++++ monkey-bubble/src/net/Makefile.am 2011-07-02 19:06:46.849604295 +0200
+@@ -28,10 +28,10 @@
+ monkey_srv_LDFLAGS =
+
+ monkey_srv_LDADD = \
+- $(MONKEY_SRV_LIBS) \
+ libmonkeynet.a \
+ ../monkey/libmonkey.a \
+- ../util/libmonkeyutil.a
++ ../util/libmonkeyutil.a \
++ $(MONKEY_SRV_LIBS)
+
+ $(libmonkeynet_a_OBJECTS): $(marshal_sources)
+