summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArpan Kapoor2017-07-31 00:02:11 +0530
committerArpan Kapoor2017-07-31 00:02:11 +0530
commit3779af02956540fc1fcadc0b9e134b8e12370743 (patch)
treed3b584d1a86905baa54e75d864b70a235569033d
parent3e9d5d57e166f69746d248b4e952f3781e3a0e22 (diff)
downloadaur-3779af02956540fc1fcadc0b9e134b8e12370743.tar.gz
Add new header <linux/sched/signal.h>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
-rw-r--r--linux-4.11.patch15
3 files changed, 23 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9c75cb3b5e9..ae541f89a378 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Apr 16 12:04:18 UTC 2017
+# Sun Jul 30 18:28:43 UTC 2017
pkgbase = 8188eu-dkms
pkgdesc = Driver for Realtek RTL8188EUS (RTL8188EUS, RTL8188ETV) WLAN
pkgver = v4.3.0.8_13968
- pkgrel = 5
+ pkgrel = 6
url = http://www.realtek.com.tw/
install = 8188eu-dkms.install
arch = any
@@ -18,6 +18,7 @@ pkgbase = 8188eu-dkms
source = linux-4.2.patch
source = linux-4.3.patch
source = linux-4.6.patch
+ source = linux-4.11.patch
source = no_debug.patch
sha256sums = c5604632f88ab6c68074635c73403a3f612f9f69b52af8fe9b96cf851db7a832
sha256sums = edaeafe28410017fabb742d6ccdf060a945150fb56e41084adb7b9dd66739e2b
@@ -28,6 +29,7 @@ pkgbase = 8188eu-dkms
sha256sums = a8621280e07d95f6aa7ae1db8a285ba512990e0af3f8f43d54bfb4d0231d2551
sha256sums = 146a8d3b931861538ee36908e28d8ad774d5de0916e01511f48d84827c59cd99
sha256sums = 936e1701b72e5ecb6b79eba722da0586cee9aabc323ddc5a69b2c07d885d1fa1
+ sha256sums = cd4f16d4a9f2eb6965e3721e6cd7aa70656a50aa2b139e0630342999bac0b2c2
sha256sums = 9b8453c15e39cf68ccc1a0d7dfb093439f89e3b2e7c40dd0fa8d0b8aa9956cdd
pkgname = 8188eu-dkms
diff --git a/PKGBUILD b/PKGBUILD
index a46c8e60390c..48c25716beb5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname='8188eu-dkms'
_pkgname="${pkgname%-*}"
pkgver='v4.3.0.8_13968'
-pkgrel='5'
+pkgrel='6'
pkgdesc='Driver for Realtek RTL8188EUS (RTL8188EUS, RTL8188ETV) WLAN'
arch=('any')
url='http://www.realtek.com.tw/'
@@ -19,6 +19,7 @@ source=("https://www.dropbox.com/s/afs5d2yfgwurqm2/${_pkgname}-${pkgver}.tar.xz"
'linux-4.2.patch'
'linux-4.3.patch'
'linux-4.6.patch'
+ 'linux-4.11.patch'
'no_debug.patch')
sha256sums=('c5604632f88ab6c68074635c73403a3f612f9f69b52af8fe9b96cf851db7a832'
'edaeafe28410017fabb742d6ccdf060a945150fb56e41084adb7b9dd66739e2b'
@@ -29,6 +30,7 @@ sha256sums=('c5604632f88ab6c68074635c73403a3f612f9f69b52af8fe9b96cf851db7a832'
'a8621280e07d95f6aa7ae1db8a285ba512990e0af3f8f43d54bfb4d0231d2551'
'146a8d3b931861538ee36908e28d8ad774d5de0916e01511f48d84827c59cd99'
'936e1701b72e5ecb6b79eba722da0586cee9aabc323ddc5a69b2c07d885d1fa1'
+ 'cd4f16d4a9f2eb6965e3721e6cd7aa70656a50aa2b139e0630342999bac0b2c2'
'9b8453c15e39cf68ccc1a0d7dfb093439f89e3b2e7c40dd0fa8d0b8aa9956cdd')
prepare() {
@@ -39,6 +41,7 @@ prepare() {
patch -p1 -i "${srcdir}/linux-4.2.patch"
patch -p1 -i "${srcdir}/linux-4.3.patch"
patch -p1 -i "${srcdir}/linux-4.6.patch"
+ patch -p1 -i "${srcdir}/linux-4.11.patch"
patch -p1 -i "${srcdir}/no_debug.patch"
# Disable power saving
diff --git a/linux-4.11.patch b/linux-4.11.patch
new file mode 100644
index 000000000000..27053c2bd428
--- /dev/null
+++ b/linux-4.11.patch
@@ -0,0 +1,15 @@
+diff --git a/include/osdep_service_linux.h b/include/osdep_service_linux.h
+index b45c848..3cf1c30 100644
+--- a/include/osdep_service_linux.h
++++ b/include/osdep_service_linux.h
+@@ -46,6 +46,9 @@
+ #endif
+ #include <linux/sem.h>
+ #include <linux/sched.h>
++#if (LINUX_VERSION_CODE >= KERNEL_VERSION(4,11,0))
++ #include <linux/sched/signal.h>
++#endif
+ #include <linux/etherdevice.h>
+ #include <linux/wireless.h>
+ #include <net/iw_handler.h>
+