summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArpan Kapoor2019-03-06 21:35:41 +0530
committerArpan Kapoor2019-03-06 21:35:41 +0530
commit39a89670ffc923125a2e48ef9c9aad96fabdca4f (patch)
tree80e50ebccae72e70c5cd1d830ab6beda1f4f50f4
parent6410121f784abce4c716485e664320749eac416f (diff)
downloadaur-39a89670ffc923125a2e48ef9c9aad96fabdca4f.tar.gz
patch for linux5
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--linux-5.0.patch16
3 files changed, 22 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8cf4a1af229..9d903394dd23 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = 8188eu-dkms
pkgdesc = Driver for Realtek RTL8188EUS (RTL8188EUS, RTL8188ETV) WLAN
pkgver = v4.3.0.8_13968
- pkgrel = 9
+ pkgrel = 10
url = http://www.realtek.com.tw/
install = 8188eu-dkms.install
arch = any
@@ -19,6 +19,7 @@ pkgbase = 8188eu-dkms
source = linux-4.11.patch
source = linux-4.15.patch
source = linux-4.19.patch
+ source = linux-5.0.patch
source = no_debug.patch
sha256sums = c5604632f88ab6c68074635c73403a3f612f9f69b52af8fe9b96cf851db7a832
sha256sums = edaeafe28410017fabb742d6ccdf060a945150fb56e41084adb7b9dd66739e2b
@@ -32,6 +33,7 @@ pkgbase = 8188eu-dkms
sha256sums = cd4f16d4a9f2eb6965e3721e6cd7aa70656a50aa2b139e0630342999bac0b2c2
sha256sums = 18c1aeb9b574c1ecd689435908adbd006bb73f2a723f319e18f044b9c3a3f6dd
sha256sums = eb1eed7298dc9ee8b39e59cc25a5ae03755337564538755d87fc808c493ac267
+ sha256sums = 0655f764a9e412ee1cb53b432938f56aa2f26f0ff28617b0b6833530a1bdb388
sha256sums = 9b8453c15e39cf68ccc1a0d7dfb093439f89e3b2e7c40dd0fa8d0b8aa9956cdd
pkgname = 8188eu-dkms
diff --git a/PKGBUILD b/PKGBUILD
index 3f2da78f571d..8b036a6236d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=8188eu
pkgname="${_pkgname}-dkms"
pkgver=v4.3.0.8_13968
-pkgrel=9
+pkgrel=10
pkgdesc='Driver for Realtek RTL8188EUS (RTL8188EUS, RTL8188ETV) WLAN'
arch=('any')
url='http://www.realtek.com.tw/'
@@ -22,6 +22,7 @@ source=("https://www.dropbox.com/s/afs5d2yfgwurqm2/${_pkgname}-${pkgver}.tar.xz?
linux-4.11.patch
linux-4.15.patch
linux-4.19.patch
+ linux-5.0.patch
no_debug.patch)
sha256sums=('c5604632f88ab6c68074635c73403a3f612f9f69b52af8fe9b96cf851db7a832'
'edaeafe28410017fabb742d6ccdf060a945150fb56e41084adb7b9dd66739e2b'
@@ -35,6 +36,7 @@ sha256sums=('c5604632f88ab6c68074635c73403a3f612f9f69b52af8fe9b96cf851db7a832'
'cd4f16d4a9f2eb6965e3721e6cd7aa70656a50aa2b139e0630342999bac0b2c2'
'18c1aeb9b574c1ecd689435908adbd006bb73f2a723f319e18f044b9c3a3f6dd'
'eb1eed7298dc9ee8b39e59cc25a5ae03755337564538755d87fc808c493ac267'
+ '0655f764a9e412ee1cb53b432938f56aa2f26f0ff28617b0b6833530a1bdb388'
'9b8453c15e39cf68ccc1a0d7dfb093439f89e3b2e7c40dd0fa8d0b8aa9956cdd')
prepare() {
diff --git a/linux-5.0.patch b/linux-5.0.patch
new file mode 100644
index 000000000000..329be5b3c28e
--- /dev/null
+++ b/linux-5.0.patch
@@ -0,0 +1,16 @@
+diff --git a/os_dep/linux/rtw_android.c b/os_dep/linux/rtw_android.c
+index d31974f..40471d8 100644
+--- a/os_dep/linux/rtw_android.c
++++ b/os_dep/linux/rtw_android.c
+@@ -546,7 +546,11 @@ int rtw_android_priv_cmd(struct net_device *net, struct ifreq *ifr, int cmd)
+ goto exit;
+ }
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(5, 0, 0)
++ if (!access_ok(priv_cmd.buf, priv_cmd.total_len)){
++#else
+ if (!access_ok(VERIFY_READ, priv_cmd.buf, priv_cmd.total_len)){
++#endif
+ DBG_871X("%s: failed to access memory\n", __FUNCTION__);
+ ret = -EFAULT;
+ goto exit;