summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArpan Kapoor2019-03-02 14:31:46 +0530
committerArpan Kapoor2019-03-02 14:31:46 +0530
commit6410121f784abce4c716485e664320749eac416f (patch)
treeed3d16e4bcce5067be5e3d969d29e9b37113fe3b
parent5d6bf311c4ade756e140e5cb0f8ba7c46a20acac (diff)
downloadaur-6410121f784abce4c716485e664320749eac416f.tar.gz
fix 4.19 issues
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--linux-4.19.patch17
3 files changed, 23 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a9d78d2185af..f8cf4a1af229 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = 8188eu-dkms
pkgdesc = Driver for Realtek RTL8188EUS (RTL8188EUS, RTL8188ETV) WLAN
pkgver = v4.3.0.8_13968
- pkgrel = 8
+ pkgrel = 9
url = http://www.realtek.com.tw/
install = 8188eu-dkms.install
arch = any
@@ -18,6 +18,7 @@ pkgbase = 8188eu-dkms
source = linux-4.6.patch
source = linux-4.11.patch
source = linux-4.15.patch
+ source = linux-4.19.patch
source = no_debug.patch
sha256sums = c5604632f88ab6c68074635c73403a3f612f9f69b52af8fe9b96cf851db7a832
sha256sums = edaeafe28410017fabb742d6ccdf060a945150fb56e41084adb7b9dd66739e2b
@@ -30,6 +31,7 @@ pkgbase = 8188eu-dkms
sha256sums = 936e1701b72e5ecb6b79eba722da0586cee9aabc323ddc5a69b2c07d885d1fa1
sha256sums = cd4f16d4a9f2eb6965e3721e6cd7aa70656a50aa2b139e0630342999bac0b2c2
sha256sums = 18c1aeb9b574c1ecd689435908adbd006bb73f2a723f319e18f044b9c3a3f6dd
+ sha256sums = eb1eed7298dc9ee8b39e59cc25a5ae03755337564538755d87fc808c493ac267
sha256sums = 9b8453c15e39cf68ccc1a0d7dfb093439f89e3b2e7c40dd0fa8d0b8aa9956cdd
pkgname = 8188eu-dkms
diff --git a/PKGBUILD b/PKGBUILD
index a9db0351f82b..3f2da78f571d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=8188eu
pkgname="${_pkgname}-dkms"
pkgver=v4.3.0.8_13968
-pkgrel=8
+pkgrel=9
pkgdesc='Driver for Realtek RTL8188EUS (RTL8188EUS, RTL8188ETV) WLAN'
arch=('any')
url='http://www.realtek.com.tw/'
@@ -21,6 +21,7 @@ source=("https://www.dropbox.com/s/afs5d2yfgwurqm2/${_pkgname}-${pkgver}.tar.xz?
linux-4.6.patch
linux-4.11.patch
linux-4.15.patch
+ linux-4.19.patch
no_debug.patch)
sha256sums=('c5604632f88ab6c68074635c73403a3f612f9f69b52af8fe9b96cf851db7a832'
'edaeafe28410017fabb742d6ccdf060a945150fb56e41084adb7b9dd66739e2b'
@@ -33,6 +34,7 @@ sha256sums=('c5604632f88ab6c68074635c73403a3f612f9f69b52af8fe9b96cf851db7a832'
'936e1701b72e5ecb6b79eba722da0586cee9aabc323ddc5a69b2c07d885d1fa1'
'cd4f16d4a9f2eb6965e3721e6cd7aa70656a50aa2b139e0630342999bac0b2c2'
'18c1aeb9b574c1ecd689435908adbd006bb73f2a723f319e18f044b9c3a3f6dd'
+ 'eb1eed7298dc9ee8b39e59cc25a5ae03755337564538755d87fc808c493ac267'
'9b8453c15e39cf68ccc1a0d7dfb093439f89e3b2e7c40dd0fa8d0b8aa9956cdd')
prepare() {
diff --git a/linux-4.19.patch b/linux-4.19.patch
new file mode 100644
index 000000000000..434022fe6441
--- /dev/null
+++ b/linux-4.19.patch
@@ -0,0 +1,17 @@
+diff --git a/os_dep/linux/os_intfs.c b/os_dep/linux/os_intfs.c
+index c1a5aaa..2d88a1b 100644
+--- a/os_dep/linux/os_intfs.c
++++ b/os_dep/linux/os_intfs.c
+@@ -630,7 +630,11 @@ unsigned int rtw_classify8021d(struct sk_buff *skb)
+
+ static u16 rtw_select_queue(struct net_device *dev, struct sk_buff *skb
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 13, 0)
+- , void *accel_priv
++ #if LINUX_VERSION_CODE < KERNEL_VERSION(4, 19, 0)
++ , void *accel_priv
++ #else
++ , struct net_device *sb_dev
++ #endif
+ #endif
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 14, 0)
+ , select_queue_fallback_t fallback